POJ 1837:Balance:动态规划_背包问题变形

Balance
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 10913 Accepted: 6787

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

这个问题一开始没有思路,想到是使用砝码去匹配挂钩,达到总和为0的匹配个数。感觉跟背包问题有点像,背包问题中有一个是,将物品放入背包恰好达到背包容量。但是这个题目跟那个的思路不太一样,还是使用动态规划去解。

动态规划的方程:dp(i,w)=∑dp(i-1,w-w(i)*location(k))  k用来遍历所有的位置。

dp(i,w)表示放置前i个砝码达到w值的放置个数,它等于将第i个砝码放置到所有第k个位置上location(k),前i-1个砝码达到w-w(i)*location(k)值的数量之和。

问题的技巧在于,位置有正有负。位置范围是-15~15,砝码最多20个,每个最重25,那么达到的w的范围是-7500~7500,统一加上7500,范围变成0~15000,达到平衡的状态 w值应该是7500

因此,

初始化:所有值为零,dp(1,w(1)*location(k))++;

返回:dp(n,7500)

package coding;

import java.util.Scanner;

class balance{
	int ln,wn;
	int[] location=new int[35];
	int[] weight=new int[25];
	int[][] train=new int[25][15005];
	Scanner cin;
	public balance(Scanner cin) {
		// TODO Auto-generated constructor stub
		this.cin=cin;
	}
	void input(){
		ln=cin.nextInt();
		wn=cin.nextInt();
		for(int i=0;i<ln;i++)
			location[i]=cin.nextInt();
		for(int i=0;i<wn;i++)
			weight[i]=cin.nextInt();
	}
	void computedp(){
		for(int i=0;i<ln;i++){
			train[0][weight[0]*location[i]+7500]++;
		}
		for(int i=1;i<wn;i++){
			for(int j=0;j<15000;j++){
				for(int k=0;k<ln;k++){
					int temp=j-weight[i]*location[k];
					if(temp>=0&&temp<=15000){
						train[i][j]+=train[i-1][temp];
					}
				}
			}
		}
	}
}
public class Main {
	public static void main(String[] srgs){
		Scanner in=new Scanner(System.in);
		while(in.hasNext()){
			balance lol=new balance(in);
			lol.input();
			lol.computedp();
			System.out.println(lol.train[lol.wn-1][7500]);
		}
	}

}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值