Arctic Network

这道题目我题意理解的有问题,是有卫星的哨所可以和其他有卫星的哨所无阻碍通信,而不是卫星可以作为中继连接两个哨所,所以s颗卫星只能减少s-1条边

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel. 
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts. 

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Input
The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).
Output
For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input
1
2 4
0 100
0 300
0 600
150 750
Sample Output
212.13

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define maxp 505
struct location
{
	double x;
	double y;
}loc[maxp];
struct list
{
	int fi;
	int la;
	double dis;
}edge[130000];
bool cmp(struct list a,struct list b)
{
	return a.dis<b.dis;
}
bool doucmp(double c,double d)
{
	return c>d;
}
int pre[maxp],s,p;
int find(int a)
{
	int r=a;
	while(r!=pre[r])
		r=pre[r];
	while(a!=pre[a])
	{
		int z;
		z=a;
		a=pre[a];
		pre[z]=r;
	}
	return r;
}
void kruskal(int n,int m)
{
	double ans[maxp]={0};
	int num_edge=0,cnt=0;;
	for(int i=0;i<=p;i++)
		pre[i]=i;
	sort(edge,edge+m,cmp);
	for(int i=0;i<m;i++)
	{
		int fa,fb;
		fa=find(edge[i].fi);
		fb=find(edge[i].la);
		if(fa!=fb)
		{
			pre[fa]=fb;
			ans[cnt++]=edge[i].dis;
			num_edge++;
			if(num_edge==n-1)
				break;
		}
	}
	sort(ans,ans+cnt,doucmp);
	printf("%.2f\n",ans[s-1]);
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int cnt=0;
		scanf("%d%d",&s,&p);
		for(int i=0;i<p;i++)
		{
			scanf("%lf%lf",&loc[i].x,&loc[i].y);
		}
		for(int i=0;i<p;i++)
		{
			for(int j=i+1;j<p;j++)
			{
				edge[cnt].fi=i;
				edge[cnt].la=j;
				edge[cnt].dis=sqrt((loc[i].x-loc[j].x)*(loc[i].x-loc[j].x)+(loc[i].y-loc[j].y)*(loc[i].y-loc[j].y));
				cnt++;
			}
		}
		kruskal(p,cnt);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值