Common Subsequence

子串:

对于一个字符串变量,例如"adereegfbw",它的子串就是像"ader"这样可以从中找到的连续的字符串。字符串"adereegfbw"本身也属于它本身最长的子串。(摘自百度百科

子序列:

数学中,某个序列子序列是从最初序列通过去除某些元素但不破坏余下元素的相对位置(在前或在后)而形成的新序列。(摘自维基百科)

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc      abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define maxn 1000
using namespace std;
int dp[maxn];
int main()
{
	char str1[maxn],str2[maxn];
	memset(str1,0,sizeof(str1));
	memset(str2,0,sizeof(str2));
	memset(dp,0,sizeof(dp));
	while(scanf("%s %s",str1,str2)!=EOF)
	{
		int len1=strlen(str1),len2=strlen(str2);
		for(int i=0;i<len2;i++)
			for(int j=0;j<len1;j++)
				if(str2[i]==str1[j])						
					dp[j+1]=dp[j]+1;
				else
					dp[j+1]=max(dp[j+1],dp[j]);
		printf("%d\n",dp[len1]);	
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值