Bing it

对于每一个点可以有两种状态转移到它:1.由前面和它相同的数字转移到它 2.由它左侧的数字转移给它

Description

I guess most of you played cards on the trip to Harbin, but I‘m sure you have never played the following card game. This card game has N rounds and 100000 types of cards numbered from 1 to 100000. A new card will be opened when each round begins. You can ``bing" this new card. And if the card you last ``bing" is the same with this new one, you will get 1 point. You can "bing" only one card, but you can change it into a new one. For example, the order of the 4 cards is 1 3 4 3. You can ``bing" 1 in the first round and change it into 3 in the second round. You get no point in the third round, but get 1 point in the last round. Additionally, there is a special card 999. If you ``bing" it and it is opened again, you will get 3 point.

Given the order of N cards, tell me the maximum points you can get.

Input

The input file will contain multiple test cases. Each test case will consist of two lines. The first line of each test case contains one integer N(2技术分享N技术分享100000). The second line of each test case contains a sequence of n integers, indicating the order of cards. A single line with the number ``0" marks the end of input; do not process this case.

Output

For each input test case, print the maximum points you can get.

Sample Input

2 
1 1 
5 
1 999 3 3 999 
0

Sample Output

1 
3
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define maxn 100005
using namespace std;
int main()
{
	int n;
	while(scanf("%d",&n),n)
	{
		int dp[maxn]={0},pre[maxn]={0},an[maxn]={0};
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&an[i]);
		}
		for(int i=1;i<=n;i++)
		{
			if(pre[an[i]]!=0)
			{
				if(an[i]==999)
				{
					dp[i]=max(dp[i-1],dp[pre[an[i]]]+3);
				}
				else
				{
					dp[i]=max(dp[i-1],dp[pre[an[i]]]+1);
				}
				pre[an[i]]=i;
			}
			else
			{
				dp[i]=dp[i-1];
				pre[an[i]]=i;
			}		
		}
		printf("%d\n",dp[n]);
	}
	return 0;
} 

#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
	int n;
	while(cin >> n,n)
	{
		int vis[100005]={0},dp[100005]={0},num;
		for(int i=1;i<=n;i++)
		{
			cin >> num;
			if(vis[num])
			{
				if(num==999)
				{
					dp[i]=max(dp[i-1],dp[vis[num]]+3);
				}		
				else
				{
					dp[i]=max(dp[i-1],dp[vis[num]]+1);
				}		
			}
			else
			{
				dp[i]=dp[i-1];
			}	
			vis[num]=i;
		}
		cout << dp[n] << endl;
	}
	return 0;
 } 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值