Max Sum Plus Plus

这道题目是求m个不相交子串,使得这些子串的和最大,对于我来说这道题目挺难的,大体说一下思路吧,假设在前面已经有了i-1个子串(i<=m),那么循环从i开始(假设每个子串都最小只有一个数字,又因为所有的子串都是不相交的,第i个子串只能从第i个数字开始),开始进行判断,是这个数字单独构成一个子串最优,还是这个数字与它前面的数字构成一个子串最优(不太会写递推公式,只能这么表述了)

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem. 

Given a consecutive number sequence S  1, S  2, S  3, S  4 ... S  x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S  x ≤ 32767). We define a function sum(i, j) = S  i + ... + S  j (1 ≤ i ≤ j ≤ n). 

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i  1, j  1) + sum(i  2, j  2) + sum(i  3, j  3) + ... + sum(i  m, j  m) maximal (i  x ≤ i  y ≤ j  x or i  x ≤ j  y ≤ j  x is not allowed). 

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i  x, j  x)(1 ≤ x ≤ m) instead. ^_^ 
Input
Each test case will begin with two integers m and n, followed by n integers S  1, S  2, S  3 ... S  n
Process to the end of file. 
Output
Output the maximal summation described above in one line. 
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8 
Hint
Huge input, scanf and dynamic programming is recommended.

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define inf 0x3fffffff
#define maxn 1000005
using namespace std;
int dp[maxn],pre[maxn],an[maxn];
int main()
{
	int m,n;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		int ans;
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&an[i]);
			dp[i]=0;
			pre[i]=0;
		}	
		dp[0]=0;
		pre[0]=0;
		for(int i=1;i<=m;i++)
		{
			ans=-inf;
			for(int j=i;j<=n;j++)
			{
				dp[j]=max(pre[j-1]+an[j],dp[j-1]+an[j]);
				pre[j-1]=ans;
				ans=max(dp[j],ans);
			}			
		}
		printf("%d\n",ans);
	}
	return 0;
} 




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值