A Knight's Journey

这道题目关键的就是字典序(题目要求字母要尽量小其次数字要尽量小,所以就是按照左上、右上、左下、右下的顺序)这就需要dir数组要有一个固定的顺序,还有就是输入时是先输入列再输入行

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
#include <stdio.h>  
#include <string.h>   
int go[8][2]= {{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
int vis[30][30];  
int n,m,flag;  
struct node  
{  
    int x,y;  
} a[30];
void dfs(int x,int y,int step)  
{  
    a[step].x=x,a[step].y=y;
    if(step==n*m)
    {  
        for(int i=1; i<=step; i++)  
            printf("%c%d",a[i].y-1+'A',a[i].x);
        printf("\n");  
        flag=1;  
    }  
    if(flag)return;  
    for(int i=0; i<8; i++)  
    {  
        int xx=x+go[i][0];  
        int yy=y+go[i][1];  
        if(xx>0&&xx<=n&&yy>0&&yy<=m&&vis[xx][yy]==0) 
        {  
            vis[xx][yy]=1;  
            dfs(xx,yy,step+1);  
            vis[xx][yy]=0;
        }  
    }  
}  
int main()  
{  
    int t,ci=1;  
    scanf("%d",&t);  
    while(t--)  
    {  
        memset(vis,0,sizeof(vis));  
        flag=0;  
        scanf("%d%d",&n,&m);  
        printf("Scenario #%d:\n",ci++);  
        vis[1][1]=1; 
        dfs(1,1,1);
        if(flag==0)
			printf("impossible\n");  
        printf("\n");  
    }  
    return 0;  
}  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值