Reward
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2971 Accepted Submission(s): 885
Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands,of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands,of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
Sample Input
2 1 1 2 2 2 1 2 2 1
Sample Output
1777 -1
Author
dandelion
Source
Recommend
yifenfei
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
const int M=10005;
struct node
{
int v;
int next;
}t[2*M];
int head[M],vis[M],in[M];
int st,num,tmp[M];
int n,m;
void add(int u,int v)
{
t[num].v=v;
t[num].next=head[u];
head[u]=num++;
}
int topo()
{
memset(vis,0,sizeof(vis));
int i,j=0,k,c=0,sum=0;
while(1)
{
k=0;
for(i=1; i<=n; i++)
{
if(!vis[i] && in[i]==0)
{
vis[i]=1;
c++;
sum+=(888+j);
tmp[k++]=i;
}
}
if(c>=n)return sum;
if(k==0)return -1;
for(i=0; i<k; i++)
{
int z=tmp[i];
for(int x=head[z]; x!=-1; x=t[x].next)
{
int v=t[x].v;
in[v]--;
}
}
j++;
}
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
memset(in,0,sizeof(in));
memset(head,-1,sizeof(head));
num=0;
int a,b;
for(int i=1; i<=m; i++)
{
scanf("%d%d",&a,&b);
in[a]++;
add(b,a);
}
printf("%d\n",topo());
}
return 0;
}