poj 1742 Coins (多重背包可行性问题)

Coins
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 28659 Accepted: 9731

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

Source


多重背包可行性,正常的三层循环算法会超时,通过添加t数组存每个硬币的使用次数,循环时判断是否超出c[i],可以降为o(n*v)的算法,大大减少时间,相当于拿空间换时间。

#include <cstdio>
#include <cstring>
int n,m,ans;
int v[105],c[105],t[100001];
bool p[100001];
int main()
{
    while(scanf("%d%d",&n,&m),n){
        for(int i=0;i<n;++i)scanf("%d",&v[i]);
        for(int i=0;i<n;++i)scanf("%d",&c[i]);
        memset(p,0,sizeof(p));
        ans=0,p[0]=1;
        for(int i=0;i<n;i++){
            memset(t,0,sizeof(t));
            for(int j=v[i];j<=m;++j)
                if(!p[j]&&p[j-v[i]]&&t[j-v[i]]<c[i])t[j]=t[j-v[i]]+1,p[j]=1,++ans;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值