POJ 1742 Coins(多重背包可行性问题)

People in Silverland use coins.They have coins of value A1,A2,A3…An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output
8
4

题意:你有N种硬币,每种硬币有价值和个数,问你用这N种硬币,能够凑出1-M这些钱的多少个。

思路:一种类似于多重背包的题目,不过是求凑成价值的个数,和求多少种取法的问题不同。dp[i][j]表示用前i种硬币能不能呢凑出j这种价值。num[i][j];表示用前i种硬币凑成价值j,时第i种用了多少枚。

代码如下:

#include<iostream>
#include<string>
#include<cmath>
#include<vector>
#include<algorithm>
#include<set>
#include<queue>

using namespace std;
const int MAX = 100010;
const int MAX_N = 110;
bool have[MAX];
int num[MAX];
pair<int,int> p[MAX_N];
int N,M;
void solve(){
    memset(have,false,sizeof(have));
    have[0] = true;
    for(int i=1;i<=N;++i){
        memset(num,0,sizeof(num));//当前硬币没有没使用所以全部置为0,
        for(int j=p[i].first;j<=M;++j){
            if(!have[j] && have[j-p[i].first] && num[j-p[i].first] < p[i].second){
                //表示这一种方案可以凑出来。
                have[j] = true;
                num[j] = num[j-p[i].first] + 1;//表示当前这种方案又是使用了一枚第i个硬币。
            }
        }
    }
    int res = 0;
    for(int i=1;i<=M;++i)
        if(have[i]){
            res++;
        }
    cout << res << endl;
}
int main(void){
    while(cin >> N >> M){
        if(N == 0 && M == 0)    break;
        for(int i=1;i<=N;++i)
            cin >> p[i].first;
        for(int i=1;i<=N;++i)
            cin >> p[i].second;
        solve();
    }


    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值