hdu 1054 Strategic Game 树形dp

8 篇文章 0 订阅

Strategic Game

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5077    Accepted Submission(s): 2326


Problem Description
Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree: 

 

the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:
 

Sample Input
  
  
4 0:(1) 1 1:(2) 2 3 2:(0) 3:(0) 5 3:(3) 1 4 2 1:(1) 0 2:(0) 0:(0) 4:(0)
 

Sample Output
  
  
1 2
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1068  1053  1150  1151  1281 
 

简单题,跟那个上司来下属就不能来的题类似

题意:派兵看守街道,求能看守所有街道的最少的兵的数量,街道用树表示,一条边两端有一点有兵就可以。

思路:dp[i][0]表示以i点为根,并且该点没有兵把守时的最小用兵量,dp[i][1]表示有兵的。

状态方程:

dp[i][0]=Σdp[j][1];

dp[i][1]=Σmin(dp[j][1],dp[j][0])+1;//j为i的子节点

叶子节点时

dp[i][0]=0;

dp[i][1]=1;

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
#include <vector>
#include <queue>
#include <map>
using namespace std;
const int N=1505;
const int inf=0x3f3f3f3f;
struct node
{
    int v,next;
}edge[2*N];
int p=1;
int n,m,u,v,val,t;
int dp[N][2],head[N];
int pow[N][55],prc[N][55];
void addedge(int i,int j)
{
    edge[p].v=j;
    edge[p].next=head[i];
    head[i]=p++;
    edge[p].v=i;
    edge[p].next=head[j];
    head[j]=p++;
}
void init(){
    p=1;
    memset(dp,inf,sizeof(dp));
    memset(head,-1,sizeof(head));
    for(int i=0;i<n;i++){
        scanf("%d:(%d)",&u,&m);
        while(m--){
            scanf("%d",&v);
            addedge(u,v);
        }
    }
}
void dfs(int u,int pre){
    dp[u][0]=0;
    dp[u][1]=1;
    for(int i=head[u];i!=-1;i=edge[i].next){
        int vt=edge[i].v;
        if(vt==pre)continue;
        dfs(vt,u);
        dp[u][0]+=dp[vt][1];
        dp[u][1]+=min(dp[vt][0],dp[vt][1]);
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF){
        init();
        dfs(0,n);
        printf("%d\n",min(dp[0][1],dp[0][0]));
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值