HDU 1054 strategic game (树形dp)

Strategic game

Time Limit: 2000MS Memory Limit: 10000K
Total Submissions: 6722 Accepted: 3095

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree. 

For example for the tree:


the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description:

  •  
  • the number of nodes
  • the description of each node in the following format
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads
    or 
    node_identifier:(0)


The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

题目大意: 给一个树,  要求在结点上放置哨兵 , 一个哨兵可以 监视 其结点的所有儿子结点以及父亲结点 , 求最少哨兵数 , 使所有结点都被监视

思路 : 这里用的树形dp , 与另一树形dp入门题类似(HDU 1520 Anniversary party)  链接: https://blog.csdn.net/no_o_ac/article/details/81124066

AC代码:

#include<vector>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn = 2000;
vector<int>v[maxn];
int vis[maxn];
int dp[maxn][2];

void init(){
    for(int i = 0;i < maxn;i ++)
        v[i].clear();
    memset(vis,0,sizeof(vis));
    for(int i = 0;i < maxn;i ++){
        dp[i][0] = 0;
        dp[i][1] = 1;
    }
}

void tree_dp(int root){
    vis[root] = 1;
    for(int i = 0;i < v[root].size();i ++){
        int s = v[root][i];
        if(!vis[s]){
            tree_dp(s);
            dp[root][0] += dp[s][1];
            dp[root][1] += min(dp[s][0],dp[s][1]);
        }
    }
}

int main()
{
    int n;
    while(~scanf("%d",&n)){
        init();
        int r,k,s,root;
        for(int i = 0;i < n;i ++){
            scanf("%d:(%d)",&r,&k);
            for(int j = 0;j < k;j ++){
                scanf("%d",&s);
                v[r].push_back(s);
                v[s].push_back(r);
            }
        }
        tree_dp(1);
        printf("%d\n",min(dp[1][0],dp[1][1]));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值