搜索练习题H-08


  
  
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111
题意:
   输入一个数n,找出一个最小的十进制数(只含有1和0),是此数可被n整除。
一个比较简单的广搜,(一般找出满足条件的最小数之类的都是广搜),以下广搜套路与细节
#include <iostream>
#include <queue>
using namespace std;
int n;
long long  solve()
{
    queue<long long>q;
    while(!q.empty())//将队列清空
    {
        q.pop();
    }
    q.push(1);
    while(1)//一直找,直到找到为止
    {
        long long  p=q.front();
        if(p%n==0)//找到
        return p;
        q.pop();
        q.push(p*10);//两种情况,这样必定只有0与1
        q.push(p*10+1);
    }
}
int main()
{
    while(cin>>n&&n)
    {
        long long res=solve();
        cout<<res<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值