2018 Multi-University Training Contest 1 C (Triangle Partition)

Problem Description
Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.
 

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000) -- the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109).
It is guaranteed that the sum of all n does not exceed 10000.
 

Output
For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n) each denoting the indices of points the i-th triangle use. If there are multiple solutions, you can output any of them.
 

Sample Input
1
1
1 2
2 3
3 5
 

Sample Output
1 2 3

题意:给出3n个点,求一种方案,其中连成n个三角形,要求每个三角形不相交。(保证没有三个点在一条直线上)

思路:按照优先x其次y最小的排序,然后依次输出三个点。因为保证了三点不共线,这样排序x与y就保证了所有三角不相交。

          这道题也不能想复杂了。

#include<bits/stdc++.h>

using namespace std;
#define ll long long
const int maxn = 3e3+10;
struct poin
{
    int x,y,id;
}G[maxn];

int cmp(poin a,poin b)
{
    if(a.x<b.x)return 1;
    else if(a.x==b.x)
    {
        if(a.y<b.y)return 1;
        return 0;
    }
    return 0;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=3*n;i++)
        {
            scanf("%d%d",&G[i].x,&G[i].y);
            G[i].id=i;
        }
        sort(G+1,G+1+3*n,cmp);
        for(int i=1;i<=3*n;i+=3)
        {
            printf("%d %d %d\n",G[i].id,G[i+1].id,G[i+2].id);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值