POJ 2752 Seek the Name, Seek the Fame【KMP--next数组】

题目:

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

 题目大意:

        给定一个字符串,求与字符串后缀 相同的所有前缀的长度【前缀、后缀长度<=字符串长度】;

解题思路:

        next [len] 存放的是 长度为 len 的字符串中,前缀=后缀的最长长度,则求出该前缀之后,该前缀 即为 该字符串中 最长的 与后缀相同的 前缀,即保留了后缀的模样,则要找到其余与后缀相同的前缀,在该前缀中找即可,应用递归,从大到小找到各个与后缀相同的前缀。

实现代码:

#include<cstdio>
#include<fstream>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstring>
#include<string.h>
#include<queue>
#include<vector>
#include<map>
using namespace std;
typedef long long ll;

char s[400000+1];
int next[400000+1];
int result[400000+1];

void get_next(char s[],int len){
    int i=0,j=-1;
    next[0]=-1;
    while(i<len){
        if(j==-1||s[i]==s[j]){
            j++; i++; next[i]=j;
        }
        else j=next[j];
    }
}

int main(){
    int count,t,i;
    memset(next,0,sizeof(0));
    while(scanf("%s",s)!=EOF){
        int len=strlen(s);
        get_next(s,len);

        // 计算结果:从字符串的尾部开始,下一个只能在与后缀相同的前缀字符串中
        count=0;
        t=next[len-1];
        while(t!=-1) {//递归
            if(s[t]==s[len-1])
                result[count++]=t+1;
            t=next[t];
        }
        // 输出结果
        for(int i=count-1;i>=0;i--)
            printf("%d ",result[i]);
        printf("%d\n",len);
    }
    return 0;
}

 

 

 

 

 

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值