poj2752

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father's name and the mother's name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

题意:给出一个字符串,询问满足前N个字符与后N个字符对应相等的n有哪些。

题解:此题考查的是KMP算法中next数组的含义,也就是求出第a个字符匹配应将指针跳转至第b个字符继续匹配,b必然是a的前后b个字符全等的最大的b,所以一个指针p从N开始每次的next[p]就是一个合法答案,然后p跳转到next[p]继续查找,直到p无next为止,将答案倒着输出即可。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cstring>
#include <vector>
#include <map>
#include <cmath>
#include<stack>
#include <set>
#include <queue>
#include <sstream>
#include <algorithm>
typedef long long ll; 
using namespace std;
int Next[400001]; 
char s[400001];
int ans[400001];
void GetNext(char* p,int Next[])
{
    int pLen = strlen(p);
    Next[0] = -1;
    int k = -1;
    int j = 0;
    while (j < pLen - 1)
    {
        //p[k]表示前缀,p[j]表示后缀
        if (k == -1 || p[j] == p[k]) 
        {
            ++k;
            ++j;
            Next[j] = k;
        }
        else 
        {
            k = Next[k]; //此时t[j] != t[k] ,所以就有 next[j+1] < k,那么求 next[j+1] 就等同于求 t[j] 往前小于 k 个的字符与 t[k] 前面的字符的最长重合串,即 t[j-k+1] ~ t[j] 与 t[0] ~ t[k-1] 的最长重合串,那么就相当于求 next[k]
        }
    }
}
int main()
 {
     while(scanf("%s", s)!=EOF)
     {
         int n = strlen(s);
         GetNext(s,Next);
         for(int i = 0; i < n; i++)
               cout<<Next[i]<<" ";
         cout<<endl;
         int tot = 0;
         int p = Next[n-1];
         while(p!=-1)
         {
             if(s[p] == s[n-1])
               ans[tot++] = p+1;
             p = Next[p];
        }
         for(int i = tot-1; i >= 0; i--)
               printf("%d ", ans[i]);
         printf("%d\n", n);
     }
 
     return 0;
 }

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值