LightOJ1284 Lights inside 3D Grid【数学--期望】

参看资料:

https://blog.csdn.net/wl16wzl/article/details/82858903


题目:

You are given a 3D grid, which has dimensions XY and Z. Each of the X x Y x Z cells contains a light. Initially all lights are off. You will have K turns. In each of the K turns,

1.      You select a cell A randomly from the grid,

2.      You select a cell B randomly from the grid and

3.      Toggle the states of all the bulbs bounded by cell A and cell B, i.e. make all the ON lights OFF and make all the OFF lights ON which are bounded by A and B. To be clear, consider cell A is (x1, y1, z1) and cell B is (x2, y2, z2). Then you have to toggle all the bulbs in grid cell (x, y, z) where min(x1, x2) ≤ x ≤ max(x1, x2)min(y1, y2) ≤ y ≤ max(y1, y2) and min(z1, z2) ≤ z ≤ max(z1, z2).

Your task is to find the expected number of lights to be ON after K turns.

Input

Input starts with an integer T (≤ 50), denoting the number of test cases.

Each case starts with a line containing four integers X, Y, Z (1 ≤ X, Y, Z ≤ 100) and K (0 ≤ K ≤ 10000).

Output

For each case, print the case number and the expected number of lights that are ON after K turns. Errors less than 10-6will be ignored.

Sample Input

5

1 2 3 5

1 1 1 1

1 2 3 0

2 3 4 1

2 3 4 2

Sample Output

Case 1: 2.9998713992

Case 2: 1

Case 3: 0

Case 4: 6.375

Case 5: 9.09765625

题目大意: 

       一个长宽高为 x,y,z 的立方网格之中,每一个节点上都有一个开关,初始状态都为关;现在有 k 次选择,每次随机选择两点,将两点确定的立方体之间 的 所有的点都按一次开关,k 次之后,求灯开着的数目的期望。

解题思路:

       单独计算每个点被选中奇数次的期望,加起来就是总亮灯数的期望。

       对于一次选取,x轴位置 i 的点,被选中的概率就是1.0减去不被选中的概率【即两个点选中的点都在 i 一侧】

              P(x,i)=1.0-1.0*((i-1)*(i-1)+(x-i)*(x-i))/(x*x)  ;

       三维坐标下被选中的概率就是三个维度概率乘起来p=P(x,i)*P(y,j)*P(z,k);

       假设选取n次,f(n)为选取n次被选中奇数次的概率,g(n)为选区n次被选中偶数次的概率

              f(n)=p*g(n-1)+(1-p)*f(n-1)

              g(n)=p*f(n-1)+(1-p)*g(n-1)

              f(n)+g(n)=1

              得f(n)=(1-2p)*f(n-1)+p,f(1)=p

              展开后为f(n)=(1-2p)^(n-1)*p+(1-2p)^(n-2)*p+......+(1-2p)*p+p

              就是一个等比数列,第一项为p,用等比求和公式得f(n)=0.5-0.5*(1-2p)^n

        f(n)就是这个点灯亮的期望

实现代码:

#include<cstdio>
#include<algorithm>
#include<string.h>
using namespace std;

double P(int i,int x){
    return 1.0-1.0*((i-1)*(i-1)+(x-i)*(x-i))/(x*x);
}

double pow1(double a,int b){
    double ret=1;
    while(b){
        if(b&1)ret=ret*a;
        a*=a;
        b>>=1;
    }
    return ret;
}

int main(){
    int T,x,y,z,k;
    scanf("%d",&T);
    for(int cas=1;cas<=T;cas++){
        scanf("%d%d%d%d",&x,&y,&z,&k);
        double ans=0;
        for(int i=1;i<=x;i++){
            for(int j=1;j<=y;j++){
                for(int s=1;s<=z;s++){
                    double p=P(i,x)*P(j,y)*P(s,z);
                    ans+=0.5-0.5*pow1(1-2*p,k);
                }
            }
        }
        printf ("Case %d: %.7f\n",cas,ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值