http://acm.hdu.edu.cn/showproblem.php?pid=1081
To The Max
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4873 Accepted Submission(s): 2302
Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4 0 -2 -7 09 2 -6 2 -4 1 -4 1-1 8 0 -2
Sample Output
15
又是一道经典的DP问题,初次见到我想大概都会想到暴力,毕竟我也是这么想的,但却是暴力肯定是不能解决问题的。
这道题是求二维子数组之和的最大值,就是在这个正方形里面取一个矩形,使得得到的数最大。
对于二维的求最大值,同样要知道求一维的最大值。(参考:DP动态规划——最大数字子串:http://blog.csdn.net/someday7_toi/article/details/7852448 )。
算法的复杂度为O( n^3 ) .
三层循环:
最外层 i 循环 n-1,表明子矩阵是从第 i 列 开始累加的。(实际上为 i+1 )
第二层 j 循环 n,表明子矩阵是从第 i 列累加到第 j 列。
第三层 k 从1 到 N 对行数 做一维 DP。(这样就保证了求出来的是矩形,即子矩阵)
b [ i ][ j ]存的是第j列中前i行的数据之和.求 m 到 n 列的和 即b[k][n]-b[k][m-1].
源代码:
#include<stdio.h>
#include<string.h>
#define M 105
int b[M][M];// b [ i ][ j ]存的是第j列中前i行的数据之和.求 m 到 n 列的和 即b[k][n]-b[k][m-1]
int main()
{
int i,j,k,sum,ans,s;
int n;
while(~scanf("%d",&n))
{
memset(b,0,sizeof(b));
ans=0;
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
{
scanf("%d",&k);
b[i][j]=b[i][j-1]+k;
}
for(i=0;i<n;i++) //代码为了方便 i 从 0 开始
{
for(j=i+1;j<=n;j++)
{
sum=0;
for(k=1;k<=n;k++) //利用一维DP的方法求最大字串
{
s=b[k][j]-b[k][i];
if(sum+s<0)
{sum=0;}
else
sum+=s;
if(sum>ans)
ans=sum;
}
}
}
printf("%d\n",ans);
}
return 0;
}
可以参考:
http://www.cnblogs.com/blackcruiser/articles/1786888.html
http://blog.csdn.net/kindlucy/article/details/5675202