ACM 杭电hdu 2602 Bone Collector(01背包)

                                             Bone Collector

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14

   一个叫做Bone Collector的男的有一个包,往包里放东西,使得其价值最大。

输入:注意是先输入的是价值,后是体积。

现在开始搞背包问题,网上看了些资料。

01 背包问题特点是:每种物品仅有一件,可以选择放或不放。用子问题定义状态:即F[i;v] 表示前i 件物品

恰放入一个容量为v的背包可以获得的最大价值。则其状态转移方程便是:
F[i;v] = maxfF[i-1;v];F[i-1;v-Ci] + Wig
这个方程非常重要,基本上所有跟背包相关的问题的方程都是由它衍生出来的。所以有必要将它详细解释一下:

“将前i 件物品放入容量为v的背包中”这个子问题,若只考虑第i 件物品的策略(放或不放),那么就可以转

化为一个只和前i-1件物品相关的问题。如果不放第i 件物品,那么问题就转化为“前i-1件物品放入容量为v的

背包中”,价值为F[i-1; v];如果放第i 件物品,那么问题就转化为“前i-1件物品放入剩下的容量为v-Ci 的

背包中”,此时能获得的最大价值就是F[i-1;v-Ci] 再加上通过放入第i 件物品获得的价值Wi。

为了方便理解这里还找了一个图。

刚刚接触这个问题不免还有有点儿不熟悉。

F[i-1,v]倒是好理解. F[i-1,v-Ci]+Wi 稍微难得看懂点。其实如果丢掉后面的 Wi,F[i-1,v-Ci]可以按照

F[i-1,v],一样理解。下面就贴代码了。。。

 

#include<stdio.h>
#include<string.h>
#define M 1009
typedef struct pack
{
	int cost;
	int val;
}PACK;
int f[M][M];
int main()
{
	int cas,n,v,i,j;

	PACK a[M];
	scanf("%d",&cas);
	while(cas--)
	{
		scanf("%d%d",&n,&v);
		memset(f,0,sizeof(f));
		for(i=1;i<=n;i++)
			scanf("%d",&a[i].val);
		for(i=1;i<=n;i++)
			scanf("%d",&a[i].cost);
		for(i=1;i<=n;i++)
			for(j=0;j<=v;j++)
				if(j-a[i].cost>=0&&f[i-1][j]<f[i-1][j-a[i].cost]+a[i].val)
					f[i][j]=f[i-1][j-a[i].cost]+a[i].val;
				else
					f[i][j]=f[i-1][j];
		printf("%d\n",f[n][v]);
	}
	return 0;
} 


 

 

注意:两个for 循环,循环条件最好不要变,对于二维的。因为循环是一层一层开始更新的;

而一维的话是始终对同一层进行修改!

一维的代码有机会再补上。

 

 

#include<stdio.h>
#include<string.h>
#define M 1009
typedef struct pack
{
	int cost;
	int val;
}PACK;
int main()
{
	int cas,n,v,i,j;
	int f[M];
	PACK a[M];
	scanf("%d",&cas);
	while(cas--)
	{
		scanf("%d%d",&n,&v);
		memset(f,0,sizeof(f));
		for(i=1;i<=n;i++)
			scanf("%d",&a[i].val);
		for(i=1;i<=n;i++)
			scanf("%d",&a[i].cost);
		for(i=1;i<=n;i++)
			for(j=v;j>=a[i].cost;j--)
				if(f[j]<f[j-a[i].cost]+a[i].val)
					f[j]=f[j-a[i].cost]+a[i].val;
		printf("%d\n",f[v]);
	}
	return 0;
}


 

  • 4
    点赞
  • 13
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值