浙大计算机研究生复试上机考试-2005年-A+B

133 篇文章 18 订阅
75 篇文章 9 订阅


A + B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7340    Accepted Submission(s): 4142


Problem Description
读入两个小于100的正整数A和B,计算A+B.
需要注意的是:A和B的每一位数字由对应的英文单词给出.
 

Input
测试输入包含若干测试用例,每个测试用例占一行,格式为"A + B =",相邻两字符串有一个空格间隔.当A和B同时为0时输入结束,相应的结果不要输出. 
 

Output
对每个测试用例输出1行,即A+B的值.
 

Sample Input
      
      
one + two = three four + five six = zero seven + eight nine = zero + zero =
 

Sample Output
      
      
3 90 96
 

Source
 


#include "iostream"  
#include "stdio.h"  
#include "math.h"  
#include "vector"  
#include "queue"  
#include "memory.h"  
#include "algorithm"  
#include "string"  
using namespace std;  
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b

int Num(char *str,int *i)
{
    int tmp;
    switch(str[(*i)])
    {
            case 'z':
                tmp=0;break;
            case 'o':
                 tmp= 1;break;
            case 't':
                 if(str[(*i)+1]=='w') tmp= 2;
                 if(str[(*i)+1]=='h') tmp= 3;
                 if(str[(*i)+1]=='e') tmp= 10;break;
            case 'f':
                 if(str[(*i)+1]=='o')tmp= 4;
                 if(str[(*i)+1]=='i')tmp= 5;break;
            case 's':
                 if(str[(*i)+1]=='i')tmp= 6;
                 if(str[(*i)+1]=='e')tmp= 7;break;
            case 'e':
                 tmp= 8;break;
            case 'n' :
                 tmp= 9;break;
    }
    while(str[++(*i)]!=' ');
    return tmp;
}

int Trans(char *str,int s,int e)
{
    int x=0,i=s,blankpos=-1,tmp;
    while(str[i]==' ')
       i++;
    tmp=Num(str,&i);
    while((str[i]==' '||str[i]=='=')&&i<=e)
       i++;
    if(i<e)
    {
        tmp*=10;
        tmp+=Num(str,&i);
    }
    return tmp;
}

int main()
{
    int x;
    char exp[40],num1[20],num2[20];
    while(gets(exp))
    {
       int i,j;
       for(i=0;i<strlen(exp);i++)
       {
           if(exp[i]=='+')
              break;
       }
       int x1=Trans(exp,0,i-1);
       int x2=Trans(exp,i+1,strlen(exp)-1);
       if(!x1&&!x2)
          break;    
       printf("%d\n",x1+x2);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值