Solaris 10 Reference Manual Collection >> man pages section 9: DDI and DKI Properties and Data Structures >> Data Structures for Drivers >> iovec(9S) – data storage structure for I/O using uio
iovec(9S)
NAME | Synopsis | Interface Level | Description | Structure Members | See Also
NAME
- iovec – data storage structure for I/O using uio
Synopsis
#include <sys/uio.h>
Interface Level
Architecture independent level 1 (DDI/DKI).
Description
An iovec structure describes a data storage area for transfer in a uio(9S) structure. Conceptually, it can be thought of as a base address and length specification.
Structure Members
-
caddr_t iov_base; /* base address of the data storage area */ /* represented by the iovec structure */ int iov_len; /* size of the data storage area in bytes */