Backward Digit Sums POJ - 3187

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

    3   1   2   4

      4   3   6

        7   9

         16

Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.、

思路:只要将数组按照字典序全排列求出和与sum进行比较就可以了

#include<iostream>
#include<cstdio>
#include<fstream>
#include<queue>
#include<vector>
#include<algorithm>
#include<cmath>
#include<cstring>
#define MAX 15
#define INF 10000000

using namespace std;

int N, sum;
 
//测试函数 
int main(){
	ifstream in ("D:\\钢铁程序员\\程序数据\\033后向数字和POJ3187.txt");//从文件读取数据流,省去手动输入的麻烦 
	if(!in){//读取如果失败 
		cout << "ERROR" << endl;
	}
	cin >> N >> sum;
	int a[MAX];
	for(int i=1; i<=N; i++)
		a[i] = i;
	//对1-N全排列求和 ==sum结束
	do{
		int n = N;
		int b[MAX];
		//把a[i]赋给b[i] 
		for(int i=1; i<=n; i++)
			b[i] = a[i];
		while(n--){
			for(int i=1; i<=n; i++){
				b[i] = b[i] + b[i+1];
			}
		}
		if(b[1] == sum){
			for(int i=1; i<=N; i++)
				cout << a[i] << " ";
			cout << endl;
			break;
		}
	}while(next_permutation(a+1,a+N+1));//对数组全排列
	in.close();//打开文件以后要关闭 
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值