FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:
3 1 2 4
4 3 6
7 9
16
Behind FJ’s back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ’s mental arithmetic capabilities.
Write a program to help FJ play the game and keep up with the cows.
输入
Line 1: Two space-separated integers: N and the final sum.
输出
Line 1: An ordering of the integers 1…N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.
样例输入
4 16
样例输出
3 1 2 4
提示
Explanation of the sample:
There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.
题解:这题用深搜回溯做,题目要求按字典顺序,因为循环是从小的开始,所以找到的第一个答案就是我们要的,直接返回就好了
#include<bits/stdc++.h>
using namespace std;
int n,p,f[11],flag,a[11];
int m[11][11];
void dfs(int k){
if(flag) return; //找到答案了返回
if(k==n){ //如果枚举n个数字了
int ans=0;
for(int i=0;i<n;i++)
m[0][i]=a[i]; //把枚举的数字赋给m数组
for(int i=1;i<n;i++)
for(int j=i;j<n;j++)
m[i][j]=m[i-1][j]+m[i-1][j-1]; //通过二维数组模拟题目向后加的过程
if(m[n-1][n-1]==p) flag=1; //最后一个数字和答案相等返回
return;
}
for(int i=1;i<=n;i++)
if(!f[i]){
f[i]=1,a[k]=i; //假设选i
dfs(k+1);
f[i]=0; //回溯
}
}
int main(){
scanf("%d%d",&n,&p);
dfs(0);
for(int i=0;i<n;i++){
printf("%d",m[0][i]);
if(i!=n-1)
printf(" ");
}
}