最小生成树 - K - The Unique MST (次小生成树)

K - The Unique MST

 

Given a connected undirected graph, tell if its minimum spanning tree is unique.


Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:
1. V' = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.
Input
The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output
For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.
Sample Input
2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2
Sample Output
3

Not Unique!

题意:找最小生成树,判断是否唯一,唯一输出最小权值和,不是的话输出Not Unique!

题解:找到最小生成树,然后找到次小生成树,看是否相等。

AC代码:

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<cmath>
using namespace std;
int n,t,m;
int sum;
int rns;
const int maxn = 105;
const int inf = 0x3f3f3f3f;
int a[maxn][maxn];
int vis[maxn],length[maxn];
int mix[maxn][maxn];
int pre[maxn];
int use[maxn][maxn];
void prim()
{
    for(int i=1;i<=n;i++)
    {
        length[i]=a[1][i];
        vis[i]=0;
        pre[i]=1;
    }
    for(int i=1;i<=n;i++)
    {
        int u=inf;
        int v;
        for(int j=1;j<=n;j++)
        {
            if(vis[j]==0&&u>length[j])
            {
                u=length[j];
                v=j;
            }
        }
        vis[v]=1;
        use[v][pre[v]]=use[pre[v]][v]=1;
        sum+=length[v];
        for(int j=1;j<=n;j++)
        {
            if(v!=j&&vis[j])
            {
                mix[v][j]=mix[j][v]=max(mix[j][pre[v]],length[v]);
            }
            if(vis[j]==0&&length[j]>a[v][j])
            {
                length[j]=a[v][j];
                pre[j]=v;
            }
        }
    }
}
void second_MST()
{
    rns=inf;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            if(i==j)continue;
            if(use[i][j]==0)rns=min(rns,sum-mix[i][j]+a[i][j]);
        }
    }
}
int main()
{
    cin>>t;
    while(t--)
    {
        sum=0;
        cin>>n>>m;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
        {
            if(i==j)a[i][j]=0;
            else a[i][j]=inf;
            use[i][j]=0;
        }
        for(int j=1;j<=m;j++)
        {
            int x,y,z;
            cin>>x>>y>>z;
            a[x][y]=a[y][x]=z;
        }
        prim();
        second_MST();
        if(rns==sum)cout<<"Not Unique!"<<endl;
        else cout<<sum<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值