POJ 2376 Cleaning Shifts

                                                Cleaning Shifts

题目链接:http://poj.org/problem?id=2376

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

题意:给定N个区间,问最少几个区间可以将1-M全覆盖。

题解:贪心算法,按端点排序后每次选择当前可以选择的最靠右的点,然后不断更新即可。

AC代码:

#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 1000007;
#define _for(i,a,b) for(int i=a;i<=b;i++)
int n,m;
struct node
{
	int x,y;
}a[maxn];
bool cmp(node p,node q)
{
	if(p.x==q.x)return p.y>q.y;
	return p.x<q.x;
}
int main(int argc, char const *argv[])
{
	cin>>n>>m;
	_for(i,1,n)
	{
		cin>>a[i].x>>a[i].y;
	}
	sort(a+1,a+1+n,cmp);
	int now = 1;
	int ans = 0;
	int temp = 0;
	while(temp<m&&now<=n)
	{
		ans++;
		int k = temp;
		if(temp+1<a[now].x)break;
		while(temp+1>=a[now].x&&now<=n)
		{
			k =max(k,a[now].y);
			now++;
		}
		temp = k;
	}
	if(temp<m)cout<<"-1"<<endl;
	else cout<<ans<<endl;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值