Description
For this problem, you will write a program that reads in a sequence of 32-bit signed integers. After each odd-indexed value is read, output the median (middle value) of the elements received so far.
Input
The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. The first line of each data set contains the data set number, followed by a space, followed by an odd decimal integer M, (1 ≤ M ≤ 9999), giving the total number of signed integers to be processed. The remaining line(s) in the dataset consists of the values, 10 per line, separated by a single space. The last line in the dataset may contain less than 10 values.
Output
For each data set the first line of output contains the data set number, a single space and the number of medians output (which should be one-half the number of input values plus one). The output medians will be on the following lines, 10 per line separated by a single space. The last line may have less than 10 elements, but at least 1 element. There should be no blank lines in the output.
Sample Input
3 1 9 1 2 3 4 5 6 7 8 9 2 9 9 8 7 6 5 4 3 2 1 3 23 23 41 13 22 -3 24 -31 -11 -8 -7 3 5 103 211 -311 -45 -67 -73 -81 -99 -33 24 56
Sample Output
1 5 1 2 3 4 5 2 5 9 8 7 6 5 3 12 23 23 22 22 13 3 5 5 3 -3 -7 -3
题意:t组样例,每次输入num和n,代表第几组样例与数字个数,每奇数次后输出当前数组的中位数。
题解:用一个小顶堆和一个大顶堆维护,也就是两个优先队列,每次将大顶堆与小顶堆判断即可,注意玄学输出。
AC代码:
#include <iostream>
#include <queue>
using namespace std;
#define _for(i,a,b) for(int i=a;i<=b;i++)
int t,n,k,a[10005];
priority_queue<int,vector<int> ,greater<int> >Q;
priority_queue<int> P;
int main(int argc, char const *argv[])
{
cin>>t;
while(t--)
{
cin>>n>>k;
while(!Q.empty())Q.pop();
while(!P.empty())P.pop();
_for(i,1,k)cin>>a[i];
cout<<n<<" "<<k/2+1<<endl;
_for(i,1,k)
{
Q.push(a[i]);
P.push(a[i]);
if(i%2==0)continue;
while(Q.top()!=P.top())
{
int g = Q.top();
int q = P.top();
Q.pop();
P.pop();
Q.push(q);
P.push(g);
}
cout<<P.top()<<" ";
if(((i+1)/2%10)==0||i==k)cout<<endl;
}
}
return 0;
}