USACO 1.4 - Mother's Milk(DFS)

Farmer John has three milking buckets of capacity A, B, and C liters.Each of the numbers A, B, and C is an integer from 1 through 20,inclusive. Initially, buckets A and B are empty while bucket C is fullof milk. Sometimes, FJ pours milk from one bucket to another until thesecond bucket is filled or the first bucket is empty. Once begun, a pourmust be completed, of course. Being thrifty, no milk may be tossed out.

Write a program to help FJ determine what amounts of milk hecan leave in bucket C when he begins with three buckets as above,pours milk among the buckets for a while, and then notes that bucketA is empty.

PROGRAM NAME: milk3

INPUT FORMAT

A single line with the three integers A, B, and C.

SAMPLE INPUT (file milk3.in)

8 9 10

OUTPUT FORMAT

A single line with a sorted list of all the possible amounts ofmilk that can be in bucket C when bucket A is empty.

SAMPLE OUTPUT (file milk3.out)

1 2 8 9 10

SAMPLE INPUT (file milk3.in)

2 5 10

SAMPLE OUTPUT (file milk3.out)

5 6 7 8 9 10

                                                             

题意:

求出杯A为空时杯C的状态。

思路:

杯A, B, C.的倒水有六种状态。DFS,使用m[i][j][k] 记录状态。

CODE:

/*
ID: sotifis3
LANG: C++
TASK: milk3
*/
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int m[30][30][30];
int a, b, c;

void dfs(int i, int j, int k)
{
    if(m[i][j][k]) return;
    m[i][j][k] = 1;
    for(int ii = 0; ii < 6; ++ii){
        int n;
        int x, y, z;
        if(ii == 0){
            n = min(i, b - j);
            x = i - n;
            y = j + n;
            z = k;
        }
        if(ii == 1){
            n = min(i, c - k);
            x = i - n;
            y = j;
            z = k + n;
        }
        if(ii == 2){
            n = min(j, a - i);
            x = i + n;
            y = j - n;
            z = k;
        }
        if(ii == 3){
            n = min(j, c - k);
            z = k + n;
            y = j - n;
            x = i;
        }
        if(ii == 4){
            n = min(k, a - i);
            x = i + n;
            y = j;
            z = k - n;
        }
        if(ii == 5){
            n = min(k, b - j);
            x = i;
            y = j + n;
            z = k - n;
        }
        dfs(x, y, z);
    }
}

int main()
{
    //freopen("in", "r", stdin);
    freopen("milk3.in","r",stdin);
    freopen("milk3.out","w",stdout);
    while(~scanf("%d %d %d", &a, &b, &c)){
        memset(m, 0, sizeof(m));
        dfs(0, 0, c);
        for(int i = 0; i < c; ++i){
            if(c - i <= b && m[0][c - i][i]) printf("%d ", i);
        }
        printf("%d\n", c);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值