Strategy Game(模拟)

Strategy Game(模拟)

题目描述

A strategy game with J players is played around a table. Players are identified by numbers from 1 to J and will play a total of R rounds.
At each round each player will play once, in the order of their identifiers; that is, player 1 will play first, player 2 will play second, and so on. Once player J plays, the round is complete, and a next round starts.
A player earns a certain amount of Victory Points every time she or he plays. After all rounds are finished the total points of each player is computed as the sum of Victory Points the player earned on
each round. The winner is the player with the maximum number of points; in case of a tie the winner is the player who earned the maximum number of points and played last.
Given the number of players, the number of rounds and a list describing the Victory Points in the order they were obtained, you must determine which player is the winner.

输入

The input contains several test cases. In each test case, the first line contains two integers J and R,respectively the number of players and the number turns (1 ≤ J, R ≤ 500). The second line contains
J ∗ R integers, representing the Victory Points earned by each player in each turn, in the order they happened. The Victory Points obtained in each turn will be always integer numbers between 0 and 100, inclusive.

输出

For each test case in the input, your program must produce one single line, containing the integer representing the winner.

样例输入 

3 3
1 1 1 1 2 2 2 3 3
2 3
0 0 1 0 2 0

样例输出 

3
1

思路:入门题,比赛时看到是英文题就没注意,后来快结束的时候读了一下题,早知道就先开这道...附上AC代码

#include<bits/stdc++.h>
using namespace std;

int main()
{
	int j = 0; int r = 0;
	
	while(cin >> j >> r)
	{
		vector<int> score(j, 0);
		for(int k = 0; k < r; ++k)
		{
			for(int i = 0; i < j; ++i)
			{
				int temp = 0;
				cin >> temp;
				score[i] += temp;
			}
		}
		
		int max = 0;
		int winner = 0;
		
		for(int i = 0; i < j; ++i)
		{
			if(score[i] >= max)
			{
				max = score[i];
				winner = i + 1;
			}
		}
	
		cout << winner << endl;
	}
	
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值