Simpsons’ Hidden Talents(kmp next数组的应用)

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7565    Accepted Submission(s): 2688


Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 

Sample Input
  
  
clinton homer riemann marjorie
 

Sample Output
  
  
0 rie 3
 

Source

把第一个字符串和第二个字符串连在一起,然后用kmp种求next数组的模板,找到这两个字符串种符合题目要求的字串。注意如果第一个字符串的长度为len1,第二个字符串的长度为len2。我们不能直接把next[len1+len2]作为结果,因为,next[len1+len2]的长度有可能大于第一个或第二个字符串。具体操作看代码。

#include<iostream>
#include<string.h>
using namespace std;
string a,b;
int _next[100005];
void Get_Next(string str)
{  
    _next[0]=-1;  
    int j=-1,i=0;  
    while(i<str.length()){  
        if(j==-1||str[j]==str[i]){  
            j++;i++;  
            _next[i]=j;  
        }  
        else j=_next[j];  
    }  
}  
int main()
{
	while(cin>>a>>b)
	{
		string c=a+b;
		Get_Next(c);
		int len=a.length()+b.length();
		int k=_next[len];
		while(k>a.length()||k>b.length())
		{
			k=_next[k];
		}
		//cout<<next[k]<<endl;
		if(k==0)
		{
			cout<<0<<endl;
		}
		else
		{
			for(int i=0;i<k;i++)
			{
				cout<<c[i];
			}
			cout<<" "<<k<<endl;
		}
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值