ArcSoft's Office Rearrangement(贪心)

ArcSoft's Office Rearrangement

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
ArcSoft, Inc. is a leading global professional computer photography and computer vision technology company.

There are  N  working blocks in ArcSoft company, which form a straight line. The CEO of ArcSoft thinks that every block should have equal number of employees, so he wants to re-arrange the current blocks into  K  new blocks by the following two operations:

- merge two neighbor blocks into a new block, and the new block's size is the sum of two old blocks'.
- split one block into two new blocks, and you can assign the size of each block, but the sum should be equal to the old block.

Now the CEO wants to know the  minimum operations to re-arrange current blocks into  K  block with equal size, please help him.
 

Input
First line contains an integer  T , which indicates the number of test cases.

Every test case begins with one line which two integers  N  and  K , which is the number of old blocks and new blocks.

The second line contains  N  numbers  a1 a2 aN , indicating the size of current blocks.

Limits
1T100
1N105
1K105
1ai105
 

Output
For every test case, you should output  'Case #x: y', where  x indicates the case number and counts from  1 and  y is the minimum operations.

If the CEO can't re-arrange  K  new blocks with equal size,  y equals  -1.
 

Sample Input
  
  
3 1 3 14 3 1 2 3 4 3 6 1 2 3
 

Sample Output
  
  
Case #1: -1 Case #2: 2 Case #3: 3

贪心即可从左往右,先判断能不能满足,每个块的个数就等于总数除以块数。然后从左往右扫,如果比最终的小那么往后加,如果比最终大,那么拆开,模拟到最后即可。

#include<iostream>
using namespace std;
long long num[100005];
int main()
{
    int cas;
    scanf("%d",&cas);
    int c=0;
    int n,k;
    while(cas--)
    {
        scanf("%d%d",&n,&k);
        long long sum=0;
        for(int i=0;i<n;i++)
        {
            scanf("%lld",&num[i]);
            sum+=num[i];
        }
        if(sum%k!=0)
        {
            printf("Case #%d: -1\n",++c);
            continue;
        }
        long long ans=0;
        long long last=sum/k;
        for(int i=0;i<n;)
        {
            if(num[i]<last)
            {
                long long now=num[i];
                int l=i+1;
                while(now<last)
                {
                    now+=num[l];
                    ans++;
                    l++;
                }
                num[l-1]=now;
                i=l-1;
            }
            else if(num[i]>last)
            {
                while(num[i]>last)
                {
                    num[i]-=last;
                    ans++;
                }
            }
            else
            {
                i++;
            }
        }
        printf("Case #%d: %lld\n",++c,ans);
    }
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值