1118. Birds in Forest (25)

1118. Birds in Forest (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<= 104) which is the number of pictures. Then N lines follow, each describes a picture in the format:
K B1 B2 ... BK
where K is the number of birds in this picture, and Bi's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

After the pictures there is a positive number Q (<= 104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line "Yes" if the two birds belong to the same tree, or "No" if not.

Sample Input:
4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7
Sample Output:
2 10
Yes
No
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <iostream>
#include <cstring>

using namespace std;

typedef long long int ll;
int a[10005];
int bird[10005];

int find_root(int *disj,int x){
	if(disj[x]<=0)
		return x;
	return disj[x] = find_root(disj,disj[x]);
}

void Union(int *disj,int root1,int root2){
	int num = disj[root1]+disj[root2];
	if( disj[root1]<disj[root2] ){
		if(disj[root2]==0)
			disj[root1] = num-1;
		else
			disj[root1] = num;
		disj[root2] = root1;
	}
	else{
		if(disj[root1]==0 && disj[root2]!=0)
			disj[root2] = num-1;
		else if(disj[root1]==0 && disj[root2]==0)
			disj[root2] = num-2;
		else
			disj[root2] = num;
		disj[root1] = root2;
	}
}


int main(){
	
	int N,K;
	scanf("%d",&N);
	int root1,root2;
	int num;
	for(int i=1; i<=N; i++){
		scanf("%d",&K);
		for(int i=1; i<=K; i++)
			scanf("%d",&a[i]);
		if(K==1){
			root1 = find_root(bird,a[1]);
			if(bird[root1]==0)
				bird[root1] = -1;
		}	
		for(int j=1; j<K; j++){
			root1 = find_root(bird,a[j]);
			root2 = find_root(bird,a[j+1]);
			if(root1!=root2)
				Union(bird,root1,root2);
		}	
	}
	int count=0,sum=0;
	for(int i=1; i<=10000; i++)
		if(bird[i]<0){
			count++;
			sum += -bird[i];
		}
	cout << count << " " << sum << endl;
	int Q;
	scanf("%d",&Q);
	int l,r;
	for(int i=1; i<=Q; i++){
		scanf("%d %d",&l,&r);
		root1 = find_root(bird,l);
		root2 = find_root(bird,r);
		if(root1==root2)
			cout << "Yes" << endl;
		else
			cout << "No" << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值