LCIS

 LCIS

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 499    Accepted Submission(s): 229


Problem Description
Alex has two sequences  a1,a2,...,an  and  b1,b2,...,bm . He wants find a longest common subsequence that consists of consecutive values in increasing order.
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first line contains two integers  n  and  m   (1n,m100000)  -- the length of two sequences. The second line contains  n  integers:  a1,a2,...,an   (1ai106) . The third line contains  n  integers:  b1,b2,...,bm   (1bi106) .

There are at most  1000  test cases and the sum of  n  and  m  does not exceed  2×106 .
 

Output
For each test case, output the length of longest common subsequence that consists of consecutive values in increasing order.
 

Sample Input
  
  
3 3 3 1 2 3 3 2 1 10 5 1 23 2 32 4 3 4 5 6 1 1 2 3 4 5 1 1 2 1
 

Sample Output
  
  
1 5 0
 
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cmath>
#include <iostream>
#include <cstring>
using namespace std;

typedef long long ll;

const int maxn = 1000005;
int a[maxn],b[maxn];

int main(){
	
	int T;
	scanf("%d",&T);
	int num;
	int N,M;
	int Max;
	while(T--){
		Max = 0;
		scanf("%d %d",&N,&M);
		for(int i=1; i<=N; i++){
			scanf("%d",&num);
			Max = max(Max,num);
			a[num] = a[num-1] + 1;
		}
		for(int i=1; i<=M; i++){
			scanf("%d",&num);
			Max = max(Max,num);
			b[num] = b[num-1] + 1;
		}
		int ans = 0;
		for(int i=1; i<=Max; i++){
			ans = max(ans,min(a[i],b[i]));
			a[i] = b[i] = 0;
		}
		printf("%d\n",ans);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值