[ACM] hdu 2844 Coins (多重背包)

286 篇文章 140 订阅
50 篇文章 0 订阅

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6347    Accepted Submission(s): 2589


Problem Description

 

Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 


 

Input

 

The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 


 

Output

 

For each test case output the answer on a single line.
 


 

Sample Input

 

  
  
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 


 

Sample Output

 

  
  
8 4
 


 

Source

 

 

解题思路:

给出一些价值的硬币,每种硬币有一定的数量,给出一个数m,问用这些硬币可以组合成价值1到m中的几个数。

代码:

#include <iostream>
#include <algorithm>
#include <string.h>
using namespace std;
const int maxn=100005;//有多少种物品
const int inf=0x7fffffff;
int c[maxn];//每种的价值
int num[maxn];//每种的数量
int f[maxn];
int v;//最大容量

void ZeroOnePack(int cost,int value)
{
    int i;
    for(i=v;i>=cost;i--)
        f[i]=max(f[i],f[i-cost]+value);
}

void CompletePack(int cost ,int value)
{
    int i;
    for(i=cost;i<=v;i++)
        f[i]=max(f[i],f[i-cost]+value);
}

void MultiPack(int cost ,int value,int amount)
{
    if(v<=cost*amount)
    {
        CompletePack(cost,value);
        return;
    }
    else
    {
        int k=1;
        while(k<amount)
        {
            ZeroOnePack(k*cost,k*value);
            amount-=k;
            k*=2;
        }
        ZeroOnePack(amount*cost,amount*value);
    }
}
int main()
{
    int n;
    while(cin>>n>>v&&(n||v))
    {
        for(int i=0;i<n;i++) cin>>c[i];
        for(int i=0;i<n;i++) cin>>num[i];
        for(int i=0;i<=v;i++)
            f[i]=-1*inf;
        f[0]=0;
        for(int i=0;i<n;i++)
            MultiPack(c[i],c[i],num[i]);
        int sum=0;
        for(int i=1;i<=v;i++)
        {
            if(f[i]>0)
                sum++;
        }
        cout<<sum<<endl;
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值