[ACM] poj 2096 Collecting Bugs (概率DP,期望)

286 篇文章 140 订阅
49 篇文章 0 订阅
Collecting Bugs
Time Limit: 10000MS Memory Limit: 64000K
Total Submissions: 2026 Accepted: 971
Case Time Limit: 2000MS Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program.
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category.
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version.
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem.
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

Source

Northeastern Europe 2004, Northern Subregion

 

解题思路:

一个软件有 s 个子系统,存在 n 种 bug。某人一天能找到一个 bug。问,在这个软件中找齐 n 种 bug,并且每个子系统中至少包含一个 bug 的时间的期望值(单位:天)。注意:bug 是无限多的,每个 bug 属于任何一种 bug 的概率都是 1/n;出现在每个系统是等可能的,为 1/s。

令 ex[i][j] 表示已经找到了 i 种 bug,且 j 个子系统至少包含一个 bug,距离完成目标需要的时间的期望。

这样说有点不好理解。换一种方法。有n个bug1有s个bug2,ex[i][j]表示为已经发现了i个bug1,j个bug2,离目标发现s个bug1,n个bug2还需要的期望天数。这样所求就是ex[0][0],而ex[n][s]则为0,因为已经全部发现,不需要额外的天数了。到下一天,可能产生四种情况,ex[i][j],没有发现任何bug,ex[i+1][j],发现一个bug1, ex[i][j+1],发现一个bug2,ex[i+1][j+1],发现两个bug,那么

ex[i][j]= 1+p1*ex[i][j] +p2*ex[i+1][j]+p3*ex[i][j+1]+p4*ex[i+1][j+1]   ,需要加1,因为是下一天

(后来右想了想,为什么由ex[i][j]可以推出四种情况,然后就可以说ex[i][j]=后面的式子呢,其实这里ex[i][j] “ 实际上”,这里说的实际,是在实际工作中,你要发现两个bug,肯定首先得发现一个bug吧,所以ex[i][j]其实是由后面那四个式子推出来的,因为我们这里ex[i][j]表示的意义就是距离完成目标还需要的时间期望。)

p1= (i/n)*(j/s)=(i*j)/(n*s)

p2=((n-i)/n)*(j/s)=(n-i)*j/(n*s)

p3=(i/n)*((s-j)/s)=i*(s-j)/(n*s)

p4=((n-i)/n)*((s-j)/s)=(n-i)*(s-j)/(n*s)

这样整理出来就是

ex[i][j]=1+ (i*j)/(n*s)*ex[i][j]+(n-i)*j/(n*s)*ex[i+1][j]+i*(s-j)/(n*s)*ex[i][j+1]+(n-i)*(s-j)/(n*s)*ex[i+1][j+1]

右边(i*j)/(n*s)*ex[i][j]移到左边合并同类项。得到:

ex[i][j]=(  1+(n-i)*j/(n*s)*ex[i+1][j]+i*(s-j)/(n*s)*ex[i][j+1]+(n-i)*(s-j)/(n*s)*ex[i+1][j+1]  )     /   (1-(i*j)/(n*s))

参考资料:

http://kicd.blog.163.com/blog/static/126961911200910168335852/

代码:

#include <iostream>
#include <string.h>
#include <iomanip>
using namespace std;
const int maxn=1005;
double ex[maxn][maxn];

int main()
{
    memset(ex,0,sizeof(ex));
    int n,s;
    cin>>n>>s;
    double m=n*s*1.0;
    for(int i=n;i>=0;i--)
        for(int j=s;j>=0;j--)
    {
        if(i==n&&j==s)
        continue;
        ex[i][j]=(1+((n-i)*(s-j)/m)*ex[i+1][j+1]+((n-i)*j/m)*ex[i+1][j]+(i*(s-j)/m)*ex[i][j+1])/(1-i*j/m);
    }
    cout<<setiosflags(ios::fixed)<<setprecision(4)<<ex[0][0];
    return 0;
}


 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值