[ACM] sdut 2882 Full Binary Tree (满二叉树的公共祖先)

Full Binary Tree

Time Limit: 2000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

In computer science, a binary tree is a tree data structure in which each node has at most two children. Consider an infinite full binary tree (each node has two children except the leaf nodes) defined as follows. For a node labelled v its left child will be labelled 2 * v and its right child will be labelled 2 * v + 1. The root is labelled as 1.
 
You are given n queries of the form i, j. For each query, you have to print the length of the shortest path between node labelled i and node labelled j.
 

输入

First line contains n(1 ≤ n ≤ 10^5), the number of queries. Each query consists of two space separated integers i and j(1 ≤ i, j ≤ 10^9) in one line.
 

输出

For each query, print the required answer in one line.
 

示例输入

5
1 2
2 3
4 3
1024 2048
3214567 9998877

示例输出

1
2
3
1
44

提示

 

来源

2014年山东省第五届ACM大学生程序设计竞赛


解题思路:

题意为一棵满二叉树,父节点编号为i,左孩子节点为i*2,右孩子节点编号为i*2+1,根节点编号为1,给定两个节点编号a,b,问a,b之间的最短路径是多少。

也就是求a,b的最近公共祖先。满二叉树每一层节点的编号x满足   2^p<=x<2^(p+1),所以先求出编号较小的数在哪一层,然后大的数跳到那一层,然后两个节点一起跳就可以了。

代码:

#include <iostream>
using namespace std;
int f[10000];//f[i]保存的是2的i次方
int len;

void pre()
{
    f[0]=1;
    for(int i=1;;i++)
    {
        f[i]=f[i-1]*2;
        if(f[i]>1e9)
        {
            len=i-1;
            break;
        }
    }
}

int a,b;
int t;
int main()
{
    pre();
    cin>>t;
    while(t--)
    {
        cin>>a>>b;
        if(a>b)
            swap(a,b);

        int step=0;
        int pos;//找到较小的数a在哪一层上,用pos保存
        for(int i=0;i<len;i++)
        {
            if(a>=f[i]&&a<f[i+1])
            {
                pos=i;
                break;
            }
        }
        while(1)//较大的数跳到与较小的数同一层上去
        {
            if(b>=f[pos]&&b<f[pos+1])
                break;
            b/=2;
            step++;
        }

        while(a!=b)//两个节点一起跳
        {
            a/=2;
            b/=2;
            step+=2;
        }
        cout<<step<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值