POJ 1157 LITTLE SHOP OF FLOWERS

LITTLE SHOP OF FLOWERS
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 21263
Accepted: 9843

Description

You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers.

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0.

V A S E S

1

2

3

4

5

Bunches

1 (azaleas)

723-5-2416

2 (begonias)

521-41023

3 (carnations)

-21

5-4-2020

According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4.

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement.

Input

  • The first line contains two numbers: F,V.
  • The following F lines: Each of these lines containsV integers, so thatAij is given as the jth number on the (i+1)st line of the input file.


  • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F.
  • F <= V <= 100 where V is the number of vases.
  • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

Output

The first line will contain the sum of aesthetic values for your arrangement.

Sample Input

3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20

Sample Output

53

Source

IOI 1999

---------------------------------华丽的分割线-------------------------------


解题思路:
题目大致意思是给出一个RxC的矩阵,要求每行都只取一个元素,第i行第j列元素记为Aij,求所有所取元素之和的最大值。
限制只有一点,若i1<i2,则j1<j2
形象地说就是取一个阶梯,使之阶梯上的元素和最大。
定义DP【i】【j】为以Aij和Arc点为边界的子阵的“阶梯”最大和。
状态转移方程:
DP【i】【j】=min{DP【i+1】【j+1】+Aij,DP【i】【j+1】};
所以对i,j倒着递推就求解,最后的答案就是DP【1】【1】(即为整个矩阵的“阶梯”最大和)
(代码中op数据表示DP,pnt表示A)

Code:
#include<stdio.h>
#include<cstring>
using namespace std;
int pnt[101][101];
int op[102][102];
int i, j, k, n, m, p,v,f;
int main()
{
    scanf("%d%d",&f,&v);
    memset(pnt,0,sizeof(pnt));
    memset(op,0,sizeof(op));
    for(i=1;i<=f;i++)
        for(j=1;j<=v;j++)
            scanf("%d",&(pnt[i][j]));
    for(i=f;i>=1;i--){
        m=-9999;
        for(j=v-(f-i);j>=1;j--){
            if(m<op[i+1][j+1]+pnt[i][j])
                m=op[i+1][j+1]+pnt[i][j];
            op[i][j]=m;
        }
    }
    printf("%d\n",op[1][1]);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值