杭电 OJ 1019 多个数的最小公倍数

Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

Sample Input
  
  
2 3 5 7 15 6 4 10296 936 1287 792 1
 

Sample Output
  
  
105 10296







要求多个数的最小公倍数,先求多个数的最大公约数。

要求多个数的最大公约数,先求两个数的最大公约数,然后结果和第三个熟求最大公约数,以此类推。。

之后A,B,...,Z的最小公倍数=A*B*.....Z/(A,B,.....Z的最大公约数)即可。


本题A*B会超过int  范围,可以选择更大的数据类型,或者采用A/GCD(A,B)*B的写法。


还要考虑只有一个数的情况!就因为这个报超时,一直卡了好久



代码:


#include <iostream>
#include <stdio.h>
using namespace std;



int LCM(int A,int B)
{
	int A1=A;
	int B1=B;
	int temp;
	while(B>0)
	{
		temp=A%B;
		A=B;
		B=temp;
	}
	return A1/A *B1;
}







int main()
{
	int n;
	int temp;
	int i=0;
	int c=0;
	int m;
	cin	>>n;
	while(n--)
	{
		scanf("%d",&m);
		if(m<=0)
		{
			continue;
		}
		if(m==1)
		{
			scanf("%d",&c);
			cout<<c<<endl;
			continue;
		}
		else
		{
			scanf("%d",&c);
			scanf("%d",&i);
			c=LCM(c,i);
			m--;
			m--;
			while(m--)
			{
				cin>>i;
				c=LCM(i,c);
			}
			printf("%d\n",c);
		}
	}
		
}





	
		


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值