1016 Phone Bills

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00

02:00, and so on for each hour in the day.
The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

题目大意:现有一个月内的电话记录,要求列出每人的所以通话记录和消费额,和最终总额。
分析:这道题目很复杂,繁琐。
难点是,找出符合题目要求的通话记录。有一方法就是,将所有通话记录一起存储,然后按照姓名与时刻进行排序。
根据排序内容,挑选每个人的有效电话记录。
参考代码:(代码转载别处,非原创)

#include<iostream>
#include<vector>
#include<map>
#include<algorithm>
#include<string>
#include<cstdio>
using namespace std;
struct node
{
    string name;
    int month, day, hour, minute, status, time;
};
bool cmp(node a, node b)
{
    return  a.name != b.name ? a.name < b.name : a.time < b.time;
}
double billFromZero(node a, int *toll)
{
    double total = 0.0;
    total = a.day*toll[24] + toll[a.hour] * a.minute;
    for (int i = 0; i < a.hour; i++)
        total += toll[i] * 60;
    total /= 100;
    return total;
}

int main()
{
    int toll[25] = { 0 };

    for (int i = 0; i < 24; i++)
    {
        cin >> toll[i];
        toll[24] += (toll[i]*60);
    }

    int n;
    string tag;
    struct node tempNode;
    vector<node>records;
    map<string, vector<node>>customers;
    cin >> n;

    //n条记录
    for (int i = 0; i < n; i++)
    {
        cin >> tempNode.name;
        scanf_s("%d:%d:%d:%d", &tempNode.month, &tempNode.day, &tempNode.hour, &tempNode.minute);

        cin >> tag;
        tag == "on-line" ? tempNode.status = 1 : tempNode.status = 0;

        //计算到某月刚开始的时间差,以分钟为单位
        tempNode.time = tempNode.day * 24 * 60 + tempNode.hour * 60 + tempNode.minute;
        records.push_back(tempNode);
    }

    sort(records.begin(), records.end(),cmp);
    //挑选符合条件的记录
    for (int i = 1; i < n; i++)
    {
        if (records[i].name == records[i - 1].name && records[i - 1].status == 1 && records[i].status == 0)
        {
            customers[records[i-1].name].push_back(records[i - 1]);
            customers[records[i].name].push_back(records[i]);
        }
    }
    //输出每个顾客的收费情况
    for (auto val : customers)
    {
        double total = 0;
        cout << val.first << " ";
        vector<node>temp = val.second;
        printf("%02d\n", temp[0].month);

        for (int i = 1; i < temp.size(); i += 2)
        {
            printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n", temp[i - 1].day, temp[i - 1].hour, temp[i - 1].minute, temp[i].day, temp[i].hour, temp[i].minute, temp[i].time - temp[i - 1].time, billFromZero(temp[i], toll) - billFromZero(temp[i - 1], toll));

            total += (billFromZero(temp[i], toll) - billFromZero(temp[i - 1], toll));
        }
        printf("Total amount: $%.2f\n", total);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值