1141 PAT Ranking of Institutions

After each PAT, the PAT Center will announce the ranking of institutions based on their students’ performances. Now you are asked to generate the ranklist.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10
​5
​​ ), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:

ID Score School
where ID is a string of 6 characters with the first one representing the test level: B stands for the basic level, A the advanced level and T the top level; Score is an integer in [0, 100]; and School is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that ID is unique for each testee.

Output Specification:
For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:

Rank School TWS Ns
where Rank is the rank (start from 1) of the institution; School is the institution code (all in lower case); ; TWS is the total weighted score which is defined to be the integer part of ScoreB/1.5 + ScoreA + ScoreT*1.5, where ScoreX is the total score of the testees belong to this institution on level X; and Ns is the total number of testees who belong to this institution.

The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

Sample Input:
10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu
Sample Output:
5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2

分析:参加pat考试,n条记录,每条记录由学生id,分数score,机构id组成。现在需要输出机构id,在机构参加考试学生的人数、所有人得分之和。

参考代码:

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
#include<map>
using namespace std;
struct node {
	node(string name):id(name){}
	string id;
	int gb=0, ga=0, gt=0, g=0, num=0, rank;
};

bool cmp(node a, node b) {
	if (a.g != b.g)
		return a.g > b.g;
	else if (a.num != b.num)
		return a.num < b.num;
	else return a.id < b.id;
}

int main()
{
	freopen("1141.txt", "r", stdin);
	int n, score, cnt = 1;
	string idPerosn, idIns;
	map<string, int>m;
	vector<node>v;
	scanf_s("%d", &n);
	for (int i = 1; i <= n; i++) {
		cin >> idPerosn >> score >> idIns;
		for (auto it = idIns.begin(); it != idIns.end(); it++) {
			*it = tolower(*it);
		}
		int temp = m[idIns];
		if (temp == 0) {
			m[idIns] = cnt++;
			v.push_back(node(idIns));
		}
		temp = m[idIns];
		if (idPerosn[0] == 'B')v[temp - 1].gb += score;
		else if (idPerosn[0] == 'A')v[temp - 1].ga += score;
		else v[temp - 1].gt += score;
		v[temp-1].num++;	
	}

	for (auto &val : v) {
		val.g = val.gb*1.0 / 1.5 + val.ga + val.gt*1.5;
	}

	sort(v.begin(), v.end(), cmp);
	for (int i = 0; i < v.size(); i++) {
		if (i == 0)v[i].rank = 1;
		else if (v[i].g == v[i - 1].g)v[i].rank = v[i - 1].rank;
		else v[i].rank = i + 1;
	}
	printf("%d\n", v.size());
	for (auto val : v) {
		printf("%d %s %d %d\n", val.rank, val.id.c_str(), val.g, val.num);
	}

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值