pat1141 PAT Ranking of Institutions (排序)

1141 PAT Ranking of Institutions (25 分)

After each PAT, the PAT Center will announce the ranking of institutions based on their students' performances. Now you are asked to generate the ranklist.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤105), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:

ID Score School

where ID is a string of 6 characters with the first one representing the test level: B stands for the basic level, A the advanced level and T the top level; Score is an integer in [0, 100]; and School is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that ID is unique for each testee.

Output Specification:

For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:

Rank School TWS Ns

where Rank is the rank (start from 1) of the institution; School is the institution code (all in lower case); ; TWS is the total weighted score which is defined to be the integer part of ScoreB/1.5 + ScoreA + ScoreT*1.5, where ScoreX is the total score of the testees belong to this institution on level X; and Ns is the total number of testees who belong to this institution.

The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in ‎字母的‎ order of their codes.

Sample Input:

10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu

Sample Output:

5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2

 题意很简单,给出每个选手的ID,分数,学校,ID第一位表示该学生参加的难度,然后将每个学校的每个级别的所有参赛选手总分记录后按照
A + B/1.5 + T×1.5 的公式计算后按总分降序排序,若分数相同则看这个学校的参赛人数,按参赛人数升序排列,若人数也相同则将学校名称按字典序从小到大排序
有个小问题就是这里的总分是the integer part of “ScoreB/1.5 + ScoreA + ScoreT×1.5” 所以是用double类型先计算然后再强转成int类型

#include <iostream>
#include "vector"
#include "unordered_map"
#include "algorithm"
using namespace std;
unordered_map<string,int> stringtoint;
unordered_map<int,string> inttostring;
struct node{
    int schoolid;
    double grade;
    int ansgrade;
    int index=0;
    int rank;
};
int index=-1;
int change(string a){
    if (stringtoint.find(a)==stringtoint.end()){
        index++;
        stringtoint[a]=index;
        inttostring[index]=a;
        return index;
    } else return stringtoint[a];
}
bool cmp(node a,node b){
    if (a.ansgrade!=b.ansgrade) return a.ansgrade>b.ansgrade;
    else if (a.index!=b.index) return a.index<b.index;
    else return inttostring[a.schoolid]<inttostring[b.schoolid];
}
int main() {
    int n;
    double grade;
    int ansgrade;
    string id,school;
    scanf("%d\n",&n);
    vector<node> ans(100010);
    for (int i = 0; i < n; ++i) {
        cin>>id;
        scanf("%lf",&grade);
        cin>>school;
        for (int j = 0; j < school.length(); ++j) {
            school[j]= tolower(school[j]);
        }
        int schoolid= change(school);
        ans[schoolid].schoolid=schoolid;
        ans[schoolid].index++;
        if (id[0]=='A')ans[schoolid].grade += grade;
        if (id[0]=='B')ans[schoolid].grade += grade/1.5;
        if (id[0]=='T')ans[schoolid].grade += 1.5*grade;
    }
    int len=inttostring.size();
    for (int i = 0; i < len; ++i) {
        ans[i].ansgrade=int(ans[i].grade);
    }
    sort(ans.begin(),ans.begin()+len, cmp);
    cout<<len<<endl;
    ans[0].rank=1;
    for (int i = 1; i < len; ++i) {
        ans[i].rank=i+1;
        if (ans[i].ansgrade==ans[i-1].ansgrade) ans[i].rank=ans[i-1].rank;
    }
    for (int i = 0; i < len; ++i) {
        cout<<ans[i].rank<<" "<<inttostring[ans[i].schoolid]<<" "<<ans[i].ansgrade<<" "<<ans[i].index<<endl;
    }
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值