1100 Mars Numbers

1100 Mars Numbers
People on Mars count their numbers with base 13:

Zero on Earth is called “tret” on Mars.
The numbers 1 to 12 on Earch is called “jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec” on Mars, respectively.
For the next higher digit, Mars people name the 12 numbers as “tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou”, respectively.
For examples, the number 29 on Earth is called “hel mar” on Mars; and “elo nov” on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:
For each number, print in a line the corresponding number in the other language.

Sample Input:
4
29
5
elo nov
tam
Sample Output:
hel mar
may
115
13
题目大意:火星数字表示法与10进制表示法之间的转换。
要注意对火星数字的分割,以便转换成10进制数。
如果有4个字符,毫无疑问是0;
3个字符,则与数组一一进行比较。
其他情况,则要分割字符串,分别确定十位和个位上的数字是什么。
参考代码:

#include<iostream>
#include<vector>
#include<string>
using namespace std;
string ge[13] = { "tret","jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec" };
string shi[13] = { "0","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy","lok", "mer", "jou" };
void func1(string num) {
	int t = stoi(num);
	if (t / 13) {
		cout << shi[t / 13];
		if (t % 13)cout << " " << ge[t % 13];
	}
	else cout << ge[t % 13];
	cout << endl;
}
void func2(string num) {
	int g = 0, s = 0;
	if (num.size() == 4) { g = 0, s = 0; }
	else if (num.size() == 3) {
		for (int j = 1; j <= 12; j++) {
			if (ge[j] == num) { g = j; break; }
			if (shi[j] == num) { s = j; break; }
		}
	}
	else {
		string part1 = num.substr(0, 3), part2 = num.substr(4, 3);
		for (int j = 1; j <= 12; j++) {
			if (ge[j] == part2) { g = j; }
			if (shi[j] == part1) { s = j; }
		}
	}
	cout << s * 13 + g << endl;
}
int main() {
	int n;
	string num;
	scanf_s("%d\n", &n);
	for (int i = 0; i < n; i++) {
		getline(cin, num);
        if (isdigit(num[0])) 
			func1(num);
		else 
			func2(num);
	}
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值