1030 Travel Plan

4 篇文章 0 订阅
4 篇文章 0 订阅

1030 Travel Plan
A traveler’s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost
where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:
For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output:
0 2 3 3 40
分析:求最短路径,如果最短路径相同,则要选择则花费最短的路径。
求最短路径的过程中,如果发现另外花费最短的路径,则修改路径以及相应的长度。

参考代码:

#include<iostream>
#include<vector>
#include<algorithm>
#define N 600
#define INF 99999999
using namespace std;
int graph[N][N], rcost[N][N];
bool visited[N];
int path[N], cost[N], dis[N];

int main() {
	int n, m, s, d;
	cin >> n >> m >> s >> d;
	fill(graph[0], graph[0] + N * N, INF);
	fill(visited, visited + N, false);
	fill(cost, cost + N, INF);
	fill(dis, dis + N, INF);
	path[s] = -1;  dis[s] = 0;  cost[s] = 0;
	for (int i = 1; i <= m; i++) {
		int a, b, tdis, tcost;
		cin >> a >> b >> tdis >> tcost;
		graph[a][b] = graph[b][a] = tdis;
		rcost[a][b] = rcost[b][a] = tcost;
	}
	for (int i = 0; i < n; i++) {       //n个结点
		int u, min = INF;
		for (int i = 0; i < n; i++) {
			if (!visited[i] && dis[i] < min) {
				u = i;
				min = dis[i];
			}
		}
		if (min == INF)break;
		visited[u] = true;
		if (u == d)break;
		for (int v = 0; v < n; v++) {
			if (graph[u][v] != INF && !visited[v]) {
				if (dis[u] + graph[u][v] < dis[v]) {
					path[v] = u;
					dis[v] = dis[u] + graph[u][v];
					cost[v] = cost[u] + rcost[u][v];
				}
				else if (dis[u] + graph[u][v] == dis[v]) {
					if (cost[u] + rcost[u][v] < cost[v]) {
						path[v] = u;
						cost[v] = cost[u] + rcost[u][v];
					}
				}
			}
		}
	}
	vector<int>finalpath;
	int temp = d;
	while (temp != -1) {
		finalpath.push_back(temp);
		temp = path[temp];
	}
	for (int i = finalpath.size() - 1; i >= 0; i--)
		cout << finalpath[i] << " ";
	cout << dis[d] << " " << cost[d];

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值