2128. 【GDOI2003】排列的编码 (Standard IO)

Description

  对于n个元素的排列P=(p1,p2,……,pn),请你编写一个程序,在不构造出所有排列的情况下,直接输出该排列在按字典序排列的字典中的序数d(p),其中p1∈{1,2,3,…,n},1<=n<=50。例如:n=4,若p=(2,3,4,1),则d(p)=10;若p=(4,2,1,3),则d(p)=21

Input

  每一行对应一个数据,格式为(n,(p1,p2,….,pn))其中n表示排列的元素个数,(p1,p2,…pn)就是这n个元素的某个排列。文件的最后一行只包含“-1”,表示输入文件结束。

Output

  对于每个数据,输出对应的d(p)。所有数据的结果都输出到一行中,用逗号分开。

Sample Input

(4,(3,2,1,4))
(5,(3,5,1,2,4))
-1

Sample Output

15,67

Data Constraint

康托展开+高精度(自行手补)

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
int a[55];
int n;
long long ans;
char s;
int dep;


const int FAC[] = {1, 1, 2, 6, 24, 120, 720, 5040, 40320, 362880};   
int cantor(int n)
{
    int x = 0;
    for (int i = 0; i <=n; ++i)
      {
        int smaller = 0;  
        for (int j = i + 1; j<=n; ++j)
         {
            if (a[j] <a[i])
                smaller++;
        }
        x+= FAC[n-i] * smaller; 
    }
    return x;  
}



int main()
 {
    while(cin>>s&&s!='-')
     {
        dep++;
        scanf("%d",&n);
        cin>>s;
        cin>>s;
        for(int i=1;i<=n;i++)
         {
         scanf("%d",&a[i]);
         cin>>s;
         }
         cin>>s;

        printf("%d",cantor(n)+1);
      }
 }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值