poj 2104 K-th Number

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1…n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: “What would be the k-th number in a[i…j] segment, if this segment was sorted?”
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2…5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n — the size of the array, and m — the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 109 by their absolute values — the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it — the k-th number in sorted a[i…j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3


Solution

题目大意是求区间[i,j]的第k小数
可以使用主席树(可持久化线段树)

可持久化数据结构是可以查询到之前的状态的东东
当然直观的想就是每次重新开一个新的,但是这样太费空间了
对于线段树来说,每次单点修改最多修改 log2n 个节点,其余的没有影响
所以我们再多开 log2n 个节点,放入新的信息。
(然而这和区间第k小值有关系吗~~~~)

可以用权值线段树,因为线段树是可持久化的,那么查询l到r区间就是你第r次插入减去第l-1次插入后的线段树的样子,在这棵权值线段树,找第k大的数。


#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;

#define N 100100
#define M 5050

struct note
{
    int sum,l,r;
};

note tree[N*50];
int t[N],num[N],a[N];
int n,m,tot;

void build(int l,int r,int &x)
{
    x=++tot;
    tree[x].sum=0;
    if (l==r) return;
    int mid=(l+r)/2;
    build(l,mid,tree[x].l);
    build(mid+1,r,tree[x].r);
}

void update(int last,int p,int l,int r,int &x)
{
    x=++tot;
    tree[x]=tree[last];
    tree[x].sum=tree[last].sum+1;
    if (l==r) return;
    int mid=(l+r)/2;
    if (p<=mid) update(tree[last].l,p,l,mid,tree[x].l);
        else update(tree[last].r,p,mid+1,r,tree[x].r);
}

int query(int s,int t,int l,int r,int k)
{
    if (l==r) return l;
    int mid=(l+r)/2;
    int cnt=tree[tree[t].l].sum-tree[tree[s].l].sum;
    if (k<=cnt) return query(tree[s].l,tree[t].l,l,mid,k);
      else return query(tree[s].r,tree[t].r,mid+1,r,k-cnt);
}

int main()
{
    scanf("%d%d",&n,&m);
    for (int i=1;i<=n;++i)
    {
      scanf("%d",&a[i]);
        num[i]=a[i];
    }
    sort(a+1,a+n+1);
    int cnt=unique(a+1,a+n+1)-a-1;
    build(1,cnt,t[0]);
    for (int i=1;i<=n;++i)
      num[i]=lower_bound(a+1,a+cnt+1,num[i])-a;
    for (int i=1;i<=n;++i)
      update(t[i-1],num[i],1,cnt,t[i]);
    for (int i=1;i<=m;++i)
    {
        int x,y,z;
        scanf("%d%d%d",&x,&y,&z);
        printf("%d\n",a[query(t[x-1],t[y],1,cnt,z)]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值