Copy and Submit II

14 篇文章 1 订阅
10 篇文章 0 订阅

Input:

Input consists of several test cases. Each test case begins with an integer n. Then it's followed by n integers a[i]

0<n<=1000000

0<=a[i]<=10000

There are 100 test cases at most. The size of input file is less than 48MB. 

Output:

Maybe you can just copy and submit. Maybe not. 

样例输入
1
233
1
666
样例输出
234
667

题目链接:https://nanti.jisuanke.com/t/26220

解析:

1.就是把题目中的递归函数给分解出来,也就是递归转化为递推的过程。

2.假设n=3,有三个数分别是a,b,c。题目的意思是求1+a+b+c+ab+ac+bc+abc;化简后也就是(1+a)*(1+b)*(1+c);

#include<iostream>
#include<cstdio> 
using namespace std;
long long M=1000000007;
long long MAXL=1000000;
long long a[1000000]; 
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		long long t=1;
		for(int i=0;i<n;i++)
		{
			 cin>>a[i];
			 t=t*(a[i]+1)%M;  //或者t=(t+(t*a[i])%M)%M;
		}
		cout<<t;
	}
 return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值