树结构练习——排序二叉树的中序遍历---2128

树结构练习——排序二叉树的中序遍历

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description
在树结构中,有一种特殊的二叉树叫做排序二叉树,直观的理解就是——(1).每个节点中包含有一个关键值 (2).任意一个节点的左子树(如果存在的话)的关键值小于该节点的关键值 (3).任意一个节点的右子树(如果存在的话)的关键值大于该节点的关键值。现给定一组数据,请你对这组数据按给定顺序建立一棵排序二叉树,并输出其中序遍历的结果。
 
Input
输入包含多组数据,每组数据格式如下。
第一行包含一个整数n,为关键值的个数,关键值用整数表示。(n<=1000)
第二行包含n个整数,保证每个整数在int范围之内。
Output
为给定的数据建立排序二叉树,并输出其中序遍历结果,每个输出占一行。
 
Example Input
1
2
2
1 20
Example Output
2
1 20
1.
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int b[1005],j=0;
struct node
{
    int key;
    struct node *left, *right;
};

void creat(struct node **p,int x)
{
    if(*p==NULL)
    {
     *p=malloc(sizeof(struct node));
     (*p)->key=x;
     (*p)->left=NULL;
     (*p)->right=NULL;
    }
    else
    {
        if((*p)->key > x)
            creat(&((*p)->left),x);
        else
            creat(&((*p)->right),x);
    }
}

void midput(struct node *root)
{
    if(root)
    {
        midput(root->left);
        b[j++]=root->key;
        midput(root->right);
    }
}

int main()
{
    int n,i,data;
    struct node *root;
    while(~scanf("%d",&n))
    {
        root=NULL;j=0;
        for(i=0; i<n; i++)
        {
            scanf("%d",&data);
            creat(&root,data);
        }
        j=0;
        midput(root);
        for(i=0;i<j;i++)
        {
          if(i!=j-1)
          printf("%d ",b[i]);
          else
          printf("%d\n",b[i]);
        }
    }

    return 0;
}




2.
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
using namespace std;

int a[1005];
int b[1005],j=0;
struct node
{
    int key;
    struct node *left, *right;
};

struct node * creat(struct node *root, int x)
{
   struct node *p;
   p=root;
    if(p==NULL)
    {
        p=(struct node *)malloc(sizeof(struct node));
        p->key=x;
        p->left=NULL;
        p->right=NULL;
    }
    else
    {
        if(p->key > x)
            p->left=creat(p->left,x);
        else
            p->right=creat( p->right,x);
    }
    return p;
}

void midput(struct node *root)
{
    if(root)
    {
        midput(root->left);
        b[j++]=root->key;
        midput(root->right);

    }
}

int main()
{
    int n,i,data;
    struct node *root;
    while(~scanf("%d",&n))
    {
        j=0;
        root=NULL;
        for(i=0; i<n; i++)
        {
            scanf("%d",&data);
            root=creat(root,data);
        }
        midput(root);
        for(i=0;i<j;i++)
        {
          if(i!=(j-1))
          printf("%d ",b[i]);
          else
          printf("%d\n",b[i]);
        }
    }

    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值