Chip Factory HDU - 5536(01字典树)

John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces n chips today, the i-th chip produced this day has a serial number si.

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:
maxi,j,k(si+sj)⊕sk

which i,j,k are three different integers between 1 and n. And ⊕ is symbol of bitwise XOR.

Can you help John calculate the checksum number of today?
Input
The first line of input contains an integer T indicating the total number of test cases.

The first line of each test case is an integer n, indicating the number of chips produced today. The next line has n integers s1,s2,…,sn, separated with single space, indicating serial number of each chip.

1≤T≤1000
3≤n≤1000
0≤si≤109
There are at most 10 testcases with n>100
Output
For each test case, please output an integer indicating the checksum number in a line.
Sample Input
2
3
1 2 3
3
100 200 300
Sample Output
6
400
求(a[i]+a[j])^a[k]的最大值。其中i,j,k不一样。
求异或最大最小之类的就是01字典树,因为字典树的时间比较可观。
因为数据量比较少,所以可以暴力去找。我们枚举两个值,去字典树中去找寻第三个值。我们一开始要把所有的值都插入到字典树中,之后枚举到它就删除掉。之后再添加上,类似于回溯法。
代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#define ll long long
using namespace std;

const int maxx=1e5+100;
struct node{
	int trie[2];
	int num;
	int flag;
}p[maxx<<2];
int a[maxx];
int n,tot;

inline void Insert(int x,int flag)
{
	int root=0;
	for(int i=31;i>=0;i--)
	{
		if(!p[root].trie[(x>>i)&1]) p[root].trie[(x>>i)&1]=++tot;
		root=p[root].trie[(x>>i)&1];
		p[root].num+=flag;
	}
	p[root].flag=x;
}
inline int Find(int x)
{
	int root=0;
	int id;
	for(int i=31;i>=0;i--)
	{
		id=(x>>i)&1;
		if(p[root].trie[id^1]&&p[p[root].trie[id^1]].num) root=p[root].trie[id^1];
		else root=p[root].trie[id];
	}
	return p[root].flag^x;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		tot=0;
		for(int i=1;i<=n;i++) 
		{
			scanf("%d",&a[i]);
			Insert(a[i],1);
		}
		int _max=0;
		for(int i=1;i<=n;i++)
		{
			Insert(a[i],-1);
			for(int j=i+1;j<=n;j++)
			{
				Insert(a[j],-1);
				int yy=Find(a[i]+a[j]);
				_max=max(_max,yy);
				Insert(a[j],1);
			}
			Insert(a[i],1);
		}
		printf("%d\n",_max);
		for(int i=0;i<=tot;i++)
		{
			p[i].num=p[i].flag=0;
			p[i].trie[0]=p[i].trie[1]=0;
		}
	}
	return 0;
}

努力加油a啊,(o)/~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值