杭电1004 Let the Balloon Rise

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 173976    Accepted Submission(s): 69319


 

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

 

Sample Input
 
5 green red blue red red 3 pink orange pink 0
 

 

Sample Output
 
red pink
 

 

Author
WU, Jiazhi
 

 

Source
 

 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1002 1008 1005 1003 1009 
 
 
题意概括:此题是让先输入一个数字,然后哦输入对应数量的字符串,比较哪一个字符串输入的次数最多,即将此字符串进行输出。如果输入的数字是0,即终止程序。
 
思路:先输入一个数字,然后判断这个数字是否为0,不为0,即进入程序。然后使用一个循环输入字符串,再使用一个循环嵌套来判断哪一个字符串输入次数最多,将此字符串进行输出。
 
代码:
package pkg1004;

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner input = new Scanner(System.in);
        int value1 = input.nextInt();
        while(value1 != 0){
                int max = 0;
                int sum = 0;
                String array2 = null;
                String[] array = new String[value1];
                for(int i = 0; i < value1; i ++){
                    array[i] = input.next();
                }
                  
               if(value1 > 1){
                for(int i = 0 ; i < value1 - 1; i ++){
                    for(int j = i + 1; j < value1; j ++){
                        if(array[j].equals(array[i]))
                            sum ++;
                      } 
                   if(sum > max){
                       max = sum;
                       array2 = array[i] ;
                   }
                 }
               }
               if(value1 > 1)
                 System.out.println(array2);
               else{
                   System.out.println(array[0]);
               }
                 value1 = input.nextInt();
                }
      }   
}

错误反思:此题错了两回。

第一次没有考虑到nextLine()和next()的区别,第一次使用了nextLine(),吃掉了回车。

第二次没有考虑到只输入一个字符串的情况,这种情况下会跳过循环嵌套,导致没有输出结果。

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值