ACM并查集The Suspects

题目:

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1


题意:

跟0一组的都是感染者,跟感染者一组的还是感染者

分析:

做此题时刚看了并查集,所以不熟很熟练,用了一个很直的办法,用一个2维数组存熟入的数据,只要这组数据有0,就将所有的父亲改为0,但是一直过不了,发现这样做其实可以做出来,但是小问题太多,而且容易出现重复的错误,联系并查集的模板,其实很简单,每一组输入时直接将相邻两个联合即可

代码:

#include<stdio.h>
using namespace std;
int f[30001],a[30001],m,n;
void intt()
{
    for(int i=0;i<=m;i++)
        f[i]=i;
}
int getf(int v)
{
    if(f[v]==v)
        return v;
    else
    {
        f[v]=getf(f[v]);
        return f[v];
    }
}
void marge(int x,int y)
{
    int t1,t2;
    t1=getf(x);
    t2=getf(y);
    if(t1!=t2)
    {
        f[t2]=t1;
    }
    return ;
}
int main()
{
    int i,j,k,x;
    while(scanf("%d %d",&m,&n)!=EOF)
    {
        if(m==0&&n==0)
            break;
        intt();
        for(i=0;i<n;i++)
        {
            scanf("%d",&x);
            for(j=0;j<x;j++)
                scanf("%d",&a[j]);
            for(k=1;k<x;k++)
                marge(a[k-1],a[k]);//两两联合
        }
        int res=0;
        for(i=0;i<m;i++)
            if(getf(f[0])==getf(f[i]))
             res++;
        printf("%d\n",res);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值