POJ - 1611 The Suspects

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1

1

题意:先给你总人数,再给你组的个数,告诉你每个组里的人,0是嫌疑人,和0一组的都是嫌疑人,如果和嫌疑人一组,也是嫌疑人,问总共有多少嫌疑人。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int father[300005];
int a[50005];
int Find(int x){
     while(x!=father[x])
        x=father[x];
     return x;
}
int main(){
    int n,m,k;
    int i,j;
    int c,b;
    while(scanf("%d%d",&n,&m) && n+m){
        for(i=0;i<n;i++)
            father[i]=i;//首先,把每个人的父亲定为自己
        while(m--){
            scanf("%d",&k);
           scanf("%d",&c);

            for(i=1;i<k;i++){
                scanf("%d",&b);
                 int f1=Find(c);//获得此时c的父亲
                int f2=Find(b);
              //  printf("c=%d b=%d f1=%d f2=%d\n",c,b,f1,f2);
                 if(f1!=f2){//如果俩不是同一个父亲,变成两个中的较小的父亲
                   if(f1<f2){
                    father[Find(b)]=f1;
                   }
                   else  father[Find(c)]=f2;
                 }
              //  printf("c=%d b=%d Fc=%d Fb=%d\n",c,b,father[Find(c)],father[Find(b)]);

            }
           // for(i=0;i<n;i++)
          //      printf("%d ",father[Find(i)]);
          //  printf("\n");
        }
        int sum=0;
        for(i=0;i<n;i++){
            if(Find(i)==0)/
                sum++;
        }
        printf("%d\n",sum);
    }

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值