ACM DP Monkey and Banana

9 篇文章 0 订阅
3 篇文章 0 订阅

题目:

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food. 

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks. 
InputThe input file will contain one or more test cases. The first line of each test case contains an integer n, 
representing the number of different blocks in the following data set. The maximum value for n is 30. 
Each of the next n lines contains three integers representing the values xi, yi and zi. 
Input is terminated by a value of zero (0) for n. 
OutputFor each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height". 
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342


题意:

给出不同的长方体长宽高,上面的长方体的长宽必须严格小于下面的长宽,求出长方体塔的最大高度

分析:

类似于求最大上升子序列的问题,用dp[i]表示前i+1个长方体可以达到的最大高度,那么用第i+1个的长宽跟之前的所有的长宽都比较,如果可以,dp[i]=dp[j]+h[i];

代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;

struct Arc//由于每个长方体有6中形态,所以先用一个结构体存储,之后再加入到下面的结构体中

{

 int a[3];

}arc[32];
struct Arc_e//用来存储每个长方体的长宽高
{
    int l;
    int w;
    int h;
}arc_e[182];
int n,dp[182];
bool cmp(const Arc_e &a,const Arc_e &b)//按长宽分别为第一第二元素有小到大排序,优化节约时间
{
    if(a.l!=b.l) return a.l<b.l;
    else if(a.w!=b.w) return a.w<b.w;
    else return 0;
}
int solve()
{
    int res=0;
    for(int i=0;i<n*6;i++)
    {
        dp[i]=arc_e[i].h;
        for(int j=0;j<i;j++)
        {
            if((arc_e[i].l>arc_e[j].l)&&(arc_e[i].w>arc_e[j].w))
                dp[i]=max(dp[i],dp[j]+arc_e[i].h);
        }
        res=max(res,dp[i]);
    }
    return res;
}
int main()
{
    int casee=0;
   while(scanf("%d",&n)!=EOF)
   {
       if(n==0)
        break;
       for(int i=0;i<n;i++)
        scanf("%d %d %d",&arc[i].a[0],&arc[i].a[1],&arc[i].a[2]);
        int k=0;
       for(int j=0;j<n;j++)
       {
           Arc_e x1,x2,x3,x4,x5,x6;
           x1.l=arc[j].a[0];
           x1.w=arc[j].a[1];
           x1.h=arc[j].a[2];
           arc_e[k++]=x1;
           x2.l=arc[j].a[0];
           x2.w=arc[j].a[2];
           x2.h=arc[j].a[1];
           arc_e[k++]=x2;
           x3.l=arc[j].a[1];
           x3.w=arc[j].a[0];
           x3.h=arc[j].a[2];
           arc_e[k++]=x3;
           x4.l=arc[j].a[1];
           x4.w=arc[j].a[2];
           x4.h=arc[j].a[0];
           arc_e[k++]=x4;
           x5.l=arc[j].a[2];
           x5.w=arc[j].a[1];
           x5.h=arc[j].a[0];
           arc_e[k++]=x5;
           x6.l=arc[j].a[2];
           x6.w=arc[j].a[0];
           x6.h=arc[j].a[1];
           arc_e[k++]=x6;
       }
       sort(arc_e,arc_e+n*6,cmp);
       printf("Case %d: maximum height = %d\n",++casee,solve());
   }
   return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值